abSynth FM - FM Synthesizer with step sequencer


(Rwatters32) #21

@boochow my version number is 1.6.12


(Rwatters32) #22

@boochow hex file seems to be fine


(Rwatters32) #23

@boochow is there anything I can change to make the volume louder because I’m getting the visuals, just the sound is so faint that I have press my ear onto it to kind of hear it


#24

@rwatters32 there is no volume control. it plays always loudest sound, but in general, the volume level is lower than usual game sound.


(Rwatters32) #25

@boochow I understand this, but absynth is making virtually no sound at all


#26

Absynth’s volume level is roughly same as the pwmtest sketch or a bit louder.
If you think absynth volume is far lower than pwmtest, there may be a problem.
Absynth has 7 preset sounds and most loud sound is tubular bells.
Please try selecting tubular bells then change notes in the sequencer view.
Is its sound volume too low?


#27

There is a hardware “hack” to make sound louder.
I have not tested it though.

http://community.arduboy.com/t/can-you-use-a-micro-usb-headphone-adapter-with-the-arduboy/2374/8


(Rwatters32) #28

@boochow yeah the volume is still very low, even with the highest setting. I have to press the arduboy against my ear to even remotely hear a sound. the sound is definitely lower than the pwmtest. so i think there my be a problem.


(Rwatters32) #29

@boochow I tried the hex once more and it still failed to give me any sound


(Scott) #30

Do you get sound from the Tunes sketch included in the Arduboy library examples?
File > Examples > Arduboy > Tunes


(Dr Hitchcock) #31

Still same issue. How would I check to see if that file is on my system? I’m running Elementary OS (Ubuntu LTS base).

From what I can tell I have Arduboy2 library in my IDE. How could I test to see if that is working properly?


#32

@drh please edit PWMDAC.cpp to change “Wiring_private.h” to “wiring_private.h”, then try to build again.
I’m not using linux version of Arduino IDE, but generally speaking, unix file systems are case-sensitive, and the accurate file.name is “wiring_private.h”.
I have also updated the github repository.


#33

I have just updated abSynth FM.
New features:

  • Sequencer has now 16 patterns. Each pattern has its own synthesizer parameter set. Hold A button to enter pattern selection mode.
  • Gate time support. “Tie” continues previous note, while “Rest” stops them. On the sequencer view, “Tie” is shown as a very small “…” icon on the center of the slider.
  • Saving to / Loading from EEPROM. Select “SAV” button in pattern select mode to save current patterns. They are automatically loaded into RAM when abSynth FM starts. Hold A button while booting to bypass loading process.
  • Sending / Receiving pattern data via serial port. You can send / receive current pattern or all 16 patterns.
  • Preset sound “Percussion”.

#34

Amazing!!! :heart_eyes: :trophy: As I was watching the video, I thought to myself “that’s great that you can save sequences to EEPROM, but I wish I could permanently store them off of the device” only to moments later learn about the serial xfer feature - WOW!! This opens up the possibility of external editors and converters too of course… :heart_eyes: :thought_balloon: :musical_score: :twisted_rightwards_arrows: :space_invader:


(Dr Hitchcock) #35

Hey @boochow, changing the case of that file name fixed it, thanks!

Now I’m having the same sound issues as the others. I’m running Arduino 1.6.12.


#36

Just wanted to report that I’m not experiencing any issues with the sound. I’m currently running https://github.com/boochow/abSynth-FM/commit/055f83f020c5e4e5e4ea0e70aad7b33342f678a8 and https://github.com/MLXXXp/Arduboy2/commit/0cb37455c62e620585fe805798609d786255f7a0 and everything’s perfectly audible. Some instruments are louder than others (Tubular Bells and Slap Bass seem to work best), but in general everything is as expected based on the videos and other games I’ve tried etc. I’m building with Arduino 1.6.11. :smile: :thumbsup: :loud_sound:


#37

@drh @rwatters32 I have added code to initialize I/O pin. Please try with the current files on the GitHub.
@ishotjr thank you for information. Now I believe that the problem is in the code, not in the hardware.


(Dr Hitchcock) #38

Thanks so much @boochow! Now we’re rock’n’rollin!


(Miloslav Číž) #39

Awesome, but is there any license info?