Adding FX Chip to Homemade Arduboy (Pro Micro)

Oh sorry about that! I should update that image.

You shouldn’t connect that diode end to RX but to the Flash chip select pin (in parallel)

So I have to connect it in pin D2 of Pro Micro. Right?

Yes the same pin where you connected the flash chip select to.

@Mr.Blinky @MLXXXp

My last question: with all these modifications (adding the Flash chip and adding “two diodes and resistor” method), will I have problems with .hex games downloaded for Arduboy?

I mean: will I be able to download .hex games and upload them (as is) on my Arduboy clone or will I have to compile the .ino files?

You can use the hex files as with the original Arduboy (FX). You do not need to recompile .ino files.

Some games may have missing sounds though as there is only 1 speaker pin available on the Pro Micro.

1 Like

@Mr.Blinky @MLXXXp

First trial failed!!! :smile: :smile: :smile:

I launched:

python flashcart-backup.py C:\1\flashcart-image.bin

then I obtained:

“Found Arduino Leonardo (COM7) at port COM7
Selecting bootloader mode…
Found Arduino Leonardo bootloader (COM8) at port COM8
Opening port …
Bootloader has no flash cart support
Write aborted!”

Which bootloader should I load, and how?

I don’t understand if it is necessary to have only the flash chip and nothing else or if I have to use as well a modchip…

You only need the flash chip.

The other chip is to burn the bootloader. If you can burn the bootloader using an ICSP then it isn’t needed.

Please, could you tell me where I can find a tutorial in order to burn the bootloader?

From what you previously said you’ve already burned a Cathy3K bootloader into a Pro Micro

However:

1 Like

I thought that simply on Arduino IDE selecting “Cathy3D” and uploading a .ino file (after compiling) automatically the bootloader was put in my Micro Pro…sorry! I didn’t know that I had to use another Arduino as “programmer”…

Anyway, I’ll follow the tutorial you linked me. Thank you very much and sorry again for my misunderstanding!

Hello!

I failed on bootloader writing…

I used an Arduino UNO as Arduino ISP Programmer (before I loaded the sketch “ArduinoISP”), then I connected Arduino UNO to my Pro Micro, using 6 pins (Miso-Mosi-Reset-Sclk-Reset-VCC-GND), then I selected “Cathy3K” as bootloader. At the end I clicked on “Burn Bootloader” and I obtained the following errors:

“avrdude: Yikes! Invalid device signature.
Double check connections and try again, or use -F to override
this check.”

I tried several times but nothing changed…

Please, could you help me? Thank you!

@Mr.Blinky gave me some tips when I had trouble and I have repeated these below:

Maybe you have a UNO that needs a 10uF(bigger will do) capacitor between reset and GND.

  • Make sure you have selected the UNO board when uploading the ArduinoISP example.
  • After uploading the ArduinoISP add the 10uF capacitor as shown below.
  • check the wiring again and check the wires connect good in the female headers of the UNO
  • select Homemade Arduboy > Leonardo > SSD1306 > Start with menu > SDA and select Arduino as ISP
  • burn the bootloader and cross your fingers

afbeelding

2 Likes

I added the 10 uF capacitor but nothing changed: same error…

What else could i check?

Did you first burn the arduino icsp program in examples onto the uno to turn it into an icsp programmer?

Of course: I did it before burning the bootloader.

Can you take a screenshot of the selected settings in the tools dropdown tab and a pic of the wiring between the uno and atmega32u4? Sorry if I’m asking a lot of questions, but this info would really help debug the problem.

1 Like

Here is the Arduino IDE settings (on bootloader burning):

111

and this is the Arduino UNO on the left (as Programmer) and the Pro Micro as “Bootloader receiver”:

Note1 : I tried as well to connect the “Reset” pin between master and slave, but nothing changed.

Note2: I tried with and without 10 uF capacitor (between Pin Reset and GND of Master) but still nothing changed.

You should connect the Reset Pin of the Pro Micro to Uno pin 10 not the reset on the ICSP header of the Uno

3 Likes

Thank you!!! It worked!!!

Finally I added a 64 Mbit flash chip (W25Q64) and I loaded the “Full Enchilda” of Arduboy FX and it worked like a charm! I’m very happy!

Thank you again!

5 Likes