ArduBall: a simple but difficult basketball game


#1

Just made my first game Arduball. It’s a sort of 1 v 1 basketball game between you and the cpu that is fairly difficult.

You can download it from media fire here: http://www.mediafire.com/file/otiblere7nb2fb5/ArduBallv1_0.arduboy


(Erwin) #2

Great!

You can also 1-click install it from http://arduboy.ried.cl :wink:


(Jesse Campbell) #3

Is the source code available?


#4

not yet. I’ll make it available when I get a chance. I’m new to github and all of this. I’m used to Visual Studio and Team Foundation Server. My code is also kinda ugly at the moment. I’ll be sure to upload the code whenever I get around to doing the next version for this.


#6

The 1-click install do not work for me. The thing tried to look for my arduboy and my arduboy keep responding by flashing green light but then nothing happened.
And I like to learn more of C++ by looking atother’s work anyway so if you give he HEX…
Nope.


(Erwin) #7

Can you record a video with the problem? which green light are you talking about?


(Kevin) #8

It might be better to start a new post documenting the problem with pictures or video.


(Pharap) #11

A) The hex file won’t tell you anything about C++. The hex file is a text file that encodes avr machine code.
B) The hex is stored inside the .arduboy format, all you have to do is unzip it.

It is normal.
It’s not the only way, but it works and people use it.

The alternatives for installing hex files can be a bit fiddly.

As far as I’m aware, the Arduino IDE is only useful for games that release their source code. Not all games do release their source code. Not providing source code is discouraged, but people are free to withold their source code if they don’t want to share it.


#12

I know HEX because I had opened up one in notepad and…
Well probably only my Arduboy have a idea on what is that…
As for the source code, I believe that people do have rights to not release their code(although I am about to be more than certainly to do so)
And Arduino IDE was yea, only capable of opening up draft files and ino. files.
And guess what?
My laptop have two USB port. Primary USB 2.0 use a… driver by microsoft but the secondary 3.0 one is by Foxlink or something of that nature…
YOUR ASSUMPTION… not correct. Don’t feel bad, because the computer’s made in Jul 2012-old things, and I am using it carefully so it will end up in a museum sometime in the future.
You really cannot get any factory parts beside the Chinese “Taobao”, so good thing I am currently stuck there.


(Erwin) #13

It is normal. Also you need to relax and try to solve your problem calmly

After you do that iteration about five times, post your new problem with images/videos here.

A 2012’s PC is not an old machine, and should work with Arduboy.


#14

I actually solved the problem simply by pressing “reset” button


(Erwin) #15

Well done. Press the reset button first before posting next time.


#16

Speaking of the reset button:
Press with just enough force so that the button “snaps” in and made contact. A mechanical pencil’s refill is good enough for that. If not, try again. That button is not made of steel-the black plastic there is VERY soft, so when you press it, make sure it do not feel as if it was going to be crushed to meatball.