Arduboy Assistant - Handy Arduboy Management Tool


(Holmes) #1

Arduboy Assistant - v1.1

Arduboy Assistant is a program that allows you to manage an Arduboy’s EEPROM as well as test several hardware and software components. I hope you guys find it useful! :smiley:

Features

  • EEPROM Viewer - Scroll through EEPROM to view binary data stored in the Arduboy at a given location.
  • Back-Up EEPROM - Connect your Arduboy to the Arduino IDE’s serial monitor to create a back-up of your EEPROM.
  • Restore EEPROM - Connect your Arduboy to the Arduino IDE’s serial monitor to send over data to be stored in your EEPROM, including EEPROM back-ups.
  • Clear EEPROM - Clear everything stored in the safe EEPROM area.
  • Button Test - Test your buttons on your Arduboy. If you think your A button is broken, simply wait at the title screen and the Button Test will automatically run in 12 seconds.
  • Character Test - Scroll through the Arduboy’s stored text characters.
  • LED Test - Test all 5 LED’s independently.
  • Screen Test - Test specific points on the screen to check for dead pixels or to help plot coordinates.
  • USB Transfer Test - Test transferring and receiving data via USB.

Downloads

Download HEX: http://crait.net/proj/ArduboyAssistant.hex
Download Sketch: http://crait.net/proj/ArduboyAssistant.ino

Links

Follow me on Twitter for more updates: @crait
Check out my site for more downloads: http://crait.net/?projects

Changelog

1.1: August 29, 2016

  • Fixed RAM issue that prevented other sketches from being uploaded
  • Fixed oversight in viewing EEPROM, so now it lets you view every address
  • Closed a potential hole in restoring EEPROM, which makes it a little safer
    1.0: August 24, 2016
  • Initial Release

How can I keep game saves on the EEPROM?
What does everyone do currently to backup EEPROM?
Arduboy Manager 2.0 Released!
Arduventure SE Arduboy newbie question
Lode Runner: a trilogy in four parts
Arduventure Save File
Arduboy Shield
[Solved] Do I have to flash it? After reset is not recognized by Windows
Questions about a menu in an SD project
(Tim Evans) #2

I can’t upload anything else. I can’t even reset my Arduboy. When I try to upload another sketch I get the button test.
When I try to hit the reset button and upload a sketch in the 6 second window, it just boots back up to this sketch.

Help? :frowning:


(Scott) #3

When I compile this sketch I get:
Global variables use 2,328 bytes (90%) of dynamic memory, leaving 232 bytes for local variables. Maximum is 2,560 bytes. Low memory available, stability problems may occur.

This is probably because all of the text strings are being put in RAM.
@crait Consider using the F() macro, as described near the end of the PROGMEM document.

The solution to loading a new sketch is probably the same as:
http://community.arduboy.com/t/cant-upload-anymore/2105/3


(Holmes) #4

Hey, @TimOnGaming! Thanks for downloading my program. Sorry that it “bricked” your device. Luckily, as @MLXXXp pointed out, can switch the Arduboy to flashlight mode to flash another program or game. I should have remembered to fix this oversight before releasing, but I forgot… :disappointed_relieved: Anyway, I updated the sketch to 1.1 and re-uploaded them based on @MLXXXp’s suggestions. Now, it will work without any of those problems. :smiley:

I also updated a few other things… For instance, I made EEPROM restoration a little more safer and I fixed an oversight when viewing EEPROM from a given location.


(Scott) #5

It appears that the V1.1 upload didn’t work. I still get V1.0.


(Holmes) #6

It could be a caching problem. Worked for me. :dizzy_face:


(Scott) #7

You’re probably right. I was able to download the latest using wget.


(Tim Evans) #8

Going into “Flashlight mode” totally worked. Thanks! I’ve updated to your 1.1 Assistant.


#9

Existential ArduHandy Unit.

Where’s the Exotic Butters?


(Mattia Colasanto) #10
/Users/P3RISH/Desktop/Arduboy/Funzionalità/Arduboy_Assistant/Arduboy_Assistant.ino: In function 'void loop()':
Arduboy_Assistant:185: error: 'boolcheck' was not declared in this scope
       sprintf(text, "   Red LED:      %s\n", boolcheck(led[0]));
                                                              ^
exit status 1
'boolcheck' was not declared in this scope

Help me with this error please :slight_smile:


(Holmes) #11

@P3RISH, I’m not sure why that would happen. I just recompiled the sketch to make sure everything was working. Are you sure you didn’t copy/paste part of the code or possibly delete some by accident? The only thing I could suggest is try downloading the file once more. This really isn’t a library issue or anything like that.

Um. :open_mouth: Huh??


(Mattia Colasanto) #12

I tried but this doesn’t work…


(Kevin) #13

What version of arduino are you using @P3RISH


(Mattia Colasanto) #14

Arduino 1.6.13 :smiley:


(Kevin) #15

Arduino changed their build environment in 1.6.10 and seems to be continuing to modify it in subsequent versions. You might try 1.6.9 as a starting point, but it would be interesting to know at which version it fails. I think @crait has been using 1.6.12 perhaps?


(Holmes) #16

I’ve only ever used 1.6.11 for anything. :stuck_out_tongue: Not sure how to help. I don’t see how that error would even be possible, but then again, I don’t have that version of the IDE. When I have time, I’ll update and look more into it. Sorry if I don’t have a straight-forward answer.


(Kevin) #17

It looks like they got rid of boolcheck at some point


(Scott) #18

boolcheck() is a function in the ArduboyAssistant.ino file itself. You can find it at the very end of the file.

I have no problems compiling it with IDE versions 1.6.9, 1.6.10, 1.6.11, 1.6.12, 1.6.13 or 1.8.0

The Arduino AVR boards version I had installed for all the above was 1.6.16
(The board version doesn’t necessarily match the IDE version.)
To check or change this version, in the IDE select:
Tools > Board: > Boards Manager...
Look for: Arduino AVR Boards by Arduino version …
Click on the entry to select and install a different version.
If there is an Update button, you can use that to update to the latest version.

To install Arduboy Assistant I just made a folder in my sketchbook called ArduboyAssistant and put a copy of ArduboyAssistant.ino into it.


(Kevin) #19

Don’t mind me,

I’m just passing through.


#20

Existential Handy Unit from Five Nights at Freddy’s: Sister Location.