Arduboy Bootloader

I am still not sure why it doesn’t work…

Application serial device (When the Game is loaded)
C:>WMIC PATH Win32_SerialPort GET name, DeviceID, PnPDeviceID
DeviceID Name PNPDeviceID
COM10 Arduino Leonardo (COM10) USB\VID_2341&PID_8036&MI_00\6&623E0E3&0&0000

Bootloader serial device (Only there for about 8 sec)
C:>WMIC PATH Win32_SerialPort GET name, DeviceID, PnPDeviceID
DeviceID Name PNPDeviceID
COM6 Arduino Leonardo bootloader (COM6) USB\VID_2341&PID_0036\5&521A615&0&10

Both VID_2341&PID_8036 and VID_2341&PID_0036 are in the source.

Service is running…
image

Strange.

I saw from the source the uploader logs errors in Windows logs > Application log. Look for Application warnings with EventID 0 in maybe there’s a hint there where it fails.

1 Like

This looks like something helpful

The description for Event ID 0 from source Application cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

Error uploading the file to the Arduboy: syntax error at custom.conf:4

The message resource is present but the message was not found in the message table

I uninstalled and reinstalled and it works now.
Thanks for all the help.

4 Likes

That is a weird error, somehow that file corrupted itself. Maybe you machine rebooted without flushing all the data to the hdd?

Anyway, good thing that it works now!