Arduboy Dead Screen [Solved]


(Finn) #1

My Arduboy worked fine for most of this year (I got it at the end of last year), but recently it has been having some issues with the screen. At first, the screen showed some dim areas, looking like OLED burn-in similar to this topic. Now, nothing displays on the screen any more, and as it was running Arduventure, I can’t even access the upload option. I used the website’s contact form a few days ago, but have received nothing in response.


(Scott) #2

You should be able to upload with Arduventure installed by holding the DOWN button while powering up and continuing to hold it during the upload. (If it’s a very old version of Arduventure, you may have to use the UP button.)


(Finn) #3

Thanks a bunch for that. Unfortunately, while the sketch uploaded perfectly, and can even stream to an Arduboy mirroring program, even a fully white screen shows nothing on the real display.


#4

Yeah sounds like a hardware issue with the OLED screen. Hopefully you can get a replacement soon.


(Kevin) #5

Please write into arduboy.com/contact and we can help you out!


(Finn) #6

Ah, sorry. Forgot about this post. I’ve already been told a replacement will be sent out to me. Thanks anyway!