Arduboy died - Only red led on when plugged


(Guillaume Stein) #1

Hi everyone,

I just received my Kickstarter Arduboy edition \o/
Everything worked perfectly, I achieved to play the preloaded game.

I plugged my Arduboy to my Mac in order to change the software.
I followed the starter guide and achieved to change many times the program, and it worked.

But for some reasons, my last upload failed and I can’t get my Arduboy back.

  • Switching it on or off without cable doesn’t do anything : everything off (screen/leds etc)
  • When I plug the Arduboy, the right led in RED lights on
  • Switching it on or off with cable doesn’t do anything : everything off except the red led
  • For some reason, the red led randomly turn off. I have to unplug/replug the cable to have it back
  • ioreg -p IOUSB returns me : picture
  • system_profiler SPUSBDataType returns me : picture
  • the Arduboy is not listed anymore in the Port list in the Arduino IDE (before the fail it was).
  • when I plug the Arduboy to a PC, it doesn’t appear it the Device Manager.
  • the reset button doesn’t do anything (I tryed every scenario with/without cable, on or off)

I don’t think this is the cable because it worked previously. But I tried another one too : same result.

I really think the arduiboy has died,
But someone may have an idea.

Thank you for reading :slight_smile:

edit : change code block to picture in order to keep the indentation.


Arduboy arrived -- bricked!?
(Ash) #2

I wouldn’t worry too much about the LED turning off, that’s I believe the charging LED, so it’s probably just turning off as the battery is full, have you tried the steps from this post?

http://community.arduboy.com/t/how-to-reset-arduboy-if-its-bricked/807


(Guillaume Stein) #3

Yes, it was the last point :frowning:


#4

i was faced the same problem as you ( PLEASE HELP - my Arduboy DIED ! ..... reset bricked Arduboy does NOT work :( ) and it is a pain to reset the arduboy with the right timing. it is all about the right timing to reset it. you may need many tries.
good luck and let us know when you got it.


Non-responsive Arduboy. Red light charge, but that's it [Solved]
(Guillaume Stein) #5

Thank you very much, it work.
You are right, I didn’t understood well the reset procedure.

What I did:
plugin in you Arduboy to your computer. Turn it off.
Open an exemple in arduino IDE and compile it.
Turn on the Arduboy, wait ~4 secs.
Light press the reset button one short time (before I keep pushing it for 6secs, I was wrong).
Wait ~5 secs and press Upload.

The selected port will be auto selected when Arduboy is in reset mode.
I had to do many tries before getting the right timing !
First try to check if your card shortly appear in the port list of the Arduino IDE.
Then try to upload a software in the right timing.

Thank you so much :smiley:


Arduboy arrived -- bricked!?
(Kevin) #6

It’s a tough dance to learn! It seems like arduino might have a fix for this that we can implement soon!


#7

great to hear that you got your arduboy “back to life”, sir :relieved:


(Ross) #8