Arduboy Driver Installation [Windows & OS X]


(Holmes) #1

Hey, guys! I thought I’d break down how to make sure you have Arduboy drivers installed properly.

macOS or OS X

Just plug in the device! Yes, that’s right! macOS should automatically come with the drivers installed.

Let me know if you think that your version of OS X or macOS is not reflecting the correct drivers and we’ll go from there.

Windows

Just plug in the device! Yes, that’s right! Windows should automatically install the drivers for your Arduboy!

But, I’ve seen some people posting that their Arduboy’s drivers were not installed properly, so to manually install them, you have 2 options:

  • Download the Arduino IDE
  • Install the drivers alone

I recommend installing the IDE, but I can understand why some people may not want that.

Installing the Arduino IDE

@bateske made a cool tutorial for this. You can follow the instructions here: [Discuss] Arduboy Quick Start Guide

Install the standalone drivers

Download and unzip the contents of this ZIP file to your desktop:
https://drive.google.com/open?id=0B6Bn2I14sS1KeEtDRmxNMndudm8

Next, open Device Manager, look for the device. (It may or may not be called Arduino Leonardo.) Right-click and click Update Driver Software.

In the pop-up, click Browse my computer for driver software.

Browse for the folder that you just unzipped and click Next.

You should be good to go! Click Close and if things aren’t working, you may try restarting your computer.

Having any problems, still?

  • “Nothing happens when I connect the USB cable!” Make sure you turn on the Arduboy before connecting the USB cable.
  • “My Arduboy is not being recognized by Windows!” You may be using a charge-only cable. Try finding another USB cable that supports data transfer.
  • “Something else is wrong!” Feel free to post below and we’ll try to solve your problem!

Arduboy Manager 2.0 Released!
[OLD] Arduboy Manager (PC)
Trouble uploading sketches!
Arduboy showing up as "Sparki Programed" in Device Manager
I have a problem uploading [Solved]
I cannot seem to get Windows 7 to recognize the Arduboy
Arduboy Bootloader
Arduboy showing up as "Sparki Programed" in Device Manager
(Scott) #2

And for almost all Linux distributions its “just plug it in”.


(Holmes) #3

Gahh! You’re right! I should have included that!!


#4

I cant seem to get my PC to recognize the Arduboy. I plug it in and the installation fails, yet in device manager I do not have an other device listing, is there any other way to add it to win7 64bit?


#5

Nevermind, tried a different USB port and its working.


(Zachary) #6

I plug the Arduboy in my computer, running Windows 10 Home, using USB 3.0 and 2.0. This is what it says:
i tried to update the drivers like you said and it didn’t work.


(Mike McRoberts) #8

Did you try restarting Windows?


(Zachary) #9

That didn’t work, i think the drivers file that you can download doesn’t have the file that is necessary or i haven’t put the file in the right place.


(Kevin) #10

You might try using another computer if you have a chance, if a new computer gives you an error then something else might be going on. Windows 10 seems to be a bit tricky though sometimes.

Uninstalling drivers and reinstalling them has worked for some people.


(Holmes) #11

This is really great advice for anyone having Arduboy issues after installing/testing the drivers.


(Jakob Ayson) #12

When I look at “other devices” it says “unknown device” how can I fix this?


(Erwin) #13

Update that “unknown device” with the instructions from the first post


(Pharap) #14

Most of the images and explanation are taken from here:

https://www.arduino.cc/en/Guide/DriverInstallation

If that helps at all.


(Pharap) #15

@crait, you have to state where you got the images from and release the main post under the CC BY-SA 3.0 licence, otherwise you’re violating the original page’s licence terms.

Also, rather than hosting potentially outdated drivers on Google Drive,
it might be better to link to the current version of the portable install from the official website and explain how to extract them.
If nothing else, it should give people peace of mind that they’re getting drivers from the official source.
(The link to get the latest version of the portable install is https://www.arduino.cc/download_handler.php.)


(Benedikt Schöps) #16

Windows recognize the arduboy and the arduino ide too, but the upload programms dont? (win10) I first installed arduventure, now i´m finished an wanted to install circuit dude.


(Holmes) #17

To upload a game onto an Arduboy with Arduventure, you need to do a special procedure.


(Nunya ) #18

Still having problems installing drivers. Wn 7 is saying I have the best driver when selecting the drivers folder. So it doesn’t install anything and ArduManager doesn’t recognize the arduboy. Which driver do I select from the driver folder?


#19

To remove the installed driver:

  • Go to device manager
  • under view, select show hidden devices
  • unfold ports

For each Arduino Leonardo and Arduino Leonardo bootloader in the list

  • right click and choose unistall
  • check the option to remove drivers and click ok

Now try installing the drivers again from the /drivers folder

You can also browse to the drivers folder, right click the arduino.inf file and choose install.