Arduboy FX Activator

Oh lord it’s the end of the battery tab. Sorry about that.

I’m pretty sure giving the SDA solder the ol’ 1-2 I think it should work.

No worries! And yeah I thought the same when I saw the back side…

Hey guys I just wanted to report back that after re-soldering SDA all is working great! The mod chip is recognized now and I am able to flash it no problem. Thanks again for all your help!


Nice work!

Hello, i have a problem, i’m in a boot loop.
I have the Arduboy Arduventure Trail of the Blade version.
I use the menu and “upload” button, holp the up button. I boot on the FX Activator, flash the mod chip (ok), then flash the bootloader. And now, i’m on a screen with Arduboy (but i just see the hald of the text) and it bootloop. What ca i do ?

(if a try during the loop to hold the up button, i have a white screen but it disapear in 2 seconds, and bootloop again)

ps : the soldering was okay, the status in FX activator was good

If I understand you correctly,

  • you upgraded your Special Edition Arduboy with a blank Mod chip.
  • You successfully uploaded the activator sketch and successfully flashed the Mod chip.
  • You tried to flash the bootloader but it failed and resulted with Arduboy being in a bootloop.

This behaviour indicates a bad solderjoint / connection on the mod chips reset pad.

Open up Arduboy and inspect and reheat / resolder the reset pad.

1 Like

It was not a blank Mod chip. It’s a pre programmed version. But the step with the RST button have no reaction, no boot on the chip. Just reboot the pre charged game.
And in the step 6 of it sayd ’ “his step can also be performed in software by using the FX Activator.” So i try to flash the bootloader.

I will try reheat / resolder tomorrow.

I couldn’t make that of your original post. A pre programmed mod chip doesn’t make a difference in your case. Because of the bad reset connection the reset button upgrade doesn’t work.

Good luck tomorrow.

1 Like

Hello again,
it works !
i heat the solding point again. :smiley:


This just came in the mail today :grin:

Now to go through the instructions on soldering it and activating it.

So excited!!!


Everything is working. Got the FX mod soldered first try no problems. Installed the activator and followed the instructions without a hitch (both mod chip and fx chip were checked in the activator). Installed mod chip, then installed bootloader, finally uploaded the supplied flash image.

Tested my ArduManFX and it was able to communicate with the bootloader just fine and upload a new flashcart image. Have a couple other projects I’m finalizing and then I can put the finishing touches on the ArduManFX tool.


Hi I’m on debian 9, is this a python3 app? I tried running the app with


I’ve tried installing

python -m pip install pyserial

but which then says its installed it but when I run it it says its not installed.

Hi, yes I wrote it for Python 3 on Windows but shoulf fork for linux as well.

I’ve seen some pyserial installments not having the tools folder. Are those present?
You could try uninstalling and reinstalling pyserial.

Would using the “portable” version work in this instance?

The all-in-one Portable version is intended for Windows. Not sure if copying those files on Linux would work.

Just a shot in the dark because I don’t know much about python.
Maybe you need to do:
python3 -m pip install pyserial


I will give that a try, I’m making a arduboy but with the 2.42 ssd1306 screen with a flash chip. In the past I’ve done one with the standard bootloader but wanted to upgrade this new one to use the FX bootloader. Is this script the best way to flash a homebrew arduboy?

The GUI script is easy to upload the flash image into the flash chip. Alternatively you could use the command line only version.

For your homebrew Arduboy it would be easiest to to have the Homemade package installed. You can select your homemade configuration, cathy3k bootloader and flash the bootloader using an ISP programmer.

Note the package doesn’t contain the most reset bootloader yet. They can be found at:

Copy them in the same path of the Homemade package.

1 Like

I decided to finally install my fx chip. I got it soldered on fine and was working on flashing it. I did all of the previous steps and everything showed successful and then I got to the point of flashing the bootloader, it did it’s thing and rebooted and now it starts to boot and show arduboy at the top but only about a third of the word appears before it reboots. It just continuously does that now so I can’t get any further. Any suggestions on what I need to do? Can I do something so that it can try to reflash again?

Check out this: