Arduboy FX Activator

Would using the “portable” version work in this instance?

The all-in-one Portable version is intended for Windows. Not sure if copying those files on Linux would work.

Just a shot in the dark because I don’t know much about python.
Maybe you need to do:
python3 -m pip install pyserial


I will give that a try, I’m making a arduboy but with the 2.42 ssd1306 screen with a flash chip. In the past I’ve done one with the standard bootloader but wanted to upgrade this new one to use the FX bootloader. Is this script the best way to flash a homebrew arduboy?

The GUI script is easy to upload the flash image into the flash chip. Alternatively you could use the command line only version.

For your homebrew Arduboy it would be easiest to to have the Homemade package installed. You can select your homemade configuration, cathy3k bootloader and flash the bootloader using an ISP programmer.

Note the package doesn’t contain the most reset bootloader yet. They can be found at:

Copy them in the same path of the Homemade package.

1 Like

I decided to finally install my fx chip. I got it soldered on fine and was working on flashing it. I did all of the previous steps and everything showed successful and then I got to the point of flashing the bootloader, it did it’s thing and rebooted and now it starts to boot and show arduboy at the top but only about a third of the word appears before it reboots. It just continuously does that now so I can’t get any further. Any suggestions on what I need to do? Can I do something so that it can try to reflash again?

Check out this:

So I got my modchip today (pre-programmed.) I got my dad to solder it in and everything worked fine - mod and flash chips detected - until I tried to flash the bootloader. First it only showed part of the logo at the top of the screen before rebooting. I tried every piece of advice on the forums I could find, to no avail. Then I turned it on once again after fiddling with the solder connections once more. Nothing on the screen at all. I tried the reset button, flashlight and safe modes and nothing could upload a new sketch to the Arduboy or even detect it. I think it’s either bricked or even completely fried on a hardware level. Somehow I can still charge it, but nothing at all displays on the screen. If my Arduboy can still be saved, can I have some suggestions for how to go about that, but if it’ll just never work again, how long will it take for a pre-modded one to arrive? It took about three months for just the mod chip to come, and I would REALLY prefer if I could be able to get back to programming soon.
Never mind, it works now - desoldered the modchip entirely and redid the joints. Also we noticed some little bits of solder beneath the chip that were probably shorting out the connections, so we removed those too. I hope this helps other people that would otherwise descend into pessimism, and can’t wait to check out all the games!


By “mod chip” do you mean the w25q chips or the flash unit?

Not sure what you mean by flash chip but the first line of the post refers to the official ‘mod chip’ flex board that contailns both the attiny85 (that programs/updates the bootloader) and the w25q128 flash chip that stores all the games.

1 Like

Sorry for the confusion. I meant the entire black flex PCB that you solder into the Arduboy. My original comment was talking about the solder joints connecting that PCB to the Arduboy and how they must not have had a good connection.

1 Like

Some time later…

I got Python working and activated my mod chip!!! :partying_face: :tada:

Inspired by the work heroic quest of @Mr.Blinky & @filmote to get this working on macOS… I tried again. (My first experience was painful enough to avoid for 1+ years…)

I’m so excited to see the script run and finally convert my OG Arduboy to a flashy FX version. Genuinely made my day!! I’m sharing my notes on GitHub, in case they are helpful :smiley:


Just a little note to avoid confusion in your GitHub notes, usually, you would add the python3 symlink in usr/local/bin to the $PATH.

1 Like

Please add to and enhance my note on GitHub! I’m hoping this can be the basis of an extended guide.


Sure. I think you’ve got pretty much everything, but I’ll try to find and add what’s missing :slight_smile: . I’ve been dabbling a bit in Python for the last few weeks (since my New Years resolution which I never thought I’d take seriously but here we are) and I can probably help the most from there.


I think I’ve got everything down! Not sure how to commit or something in your GitHub so I’ll just send it in the private messages :slightly_smiling_face: .

1 Like

Thanks @Ard_Flamingo!
@Mr.Blinky - should I create a PR? Would you like this added to the README or create a new document?

1 Like

I don’t know what ‘this’ is. If it’s useful instructions for OSX then feel free to make a PR

@Mr.Blinky - I’m currently testing an FX game, so using the activator to upload the fxdata.bin and then the .hex. Problem is, on uploading ‘development data’, the HW is reset and the outdated code is booted with newer data… this leads to corruption and the code crashing, etc.

I think on uploading ‘fxdata’, the HW unit should stay in bootloader mode (/ FX menu), awaiting a new associated hex to be uploaded. I’m not sure if that’s a Cathy3k firmware issue, or an activator script issue?

Thanks for reminding me I needed to change that, updated

1 Like