Arduboy FX Activator

Arduventure Trail Of The Blade

Yes, the Arduventure requires a special procedure to be reprogrammed. The reset button will always work, but you can also go into the menu, select “upload” and hold the up button while it resets in software.

1 Like

Actually, the DOWN button.

Ok well at some point it got changed to down apparently, but the original release it was up.

Hey guys I got my brother to solder the FX Mod Chip for me and I am able to use FX Activator to upload the HEX file and flash the Bootloader but I cannot get it to Upload Flash Image, it keeps saying “No Flash Cart Detected.”. On the Activator main screen there’s an X on FLASH CHIP and under diagnostics it says “Flash chip not found!”. What am I doing wrong? Or is there a problem with the soldering or did I get a bad cable / flash chip? :frowning:

There’s most likely a bad solder joint at the SDA pad as it’s SDA that selects the flash chip.

Each of these were verified by hand so the odds of there being a problem with the mod chip is small. The solder joints are a bit tricky so sometimes you gotta give them a second tap with the soldering iron.

It may be useful to inspect the solder joints on the chips on the mod chip too, making sure that it didn’t get damaged in shipping, but I don’t suspect that.

Also, do you have something… inside your arduboy??

image

Ok thanks for the quick response! So, I would need to have the SDA pad the one second from the left de-soldered and re-soldered? Here’s a pic of the soldering right when it was done, looks good to me but I guess looks aren’t everything huh? lol. Oh well.

BlockquoteAlso, do you have something… inside your arduboy??

Oh wow, it looks like it! Good eye! Let me open and see what that’s all about… BRB

Correct, careful with the battery! Don’t bend it up any further than that and don’t do it too many times.

image

It does very much look like SDA is our problem. You can notice that the edge of the flex PCB is pulled up a bit, and you can notice the solder joint appears to have a larger dome on the top of it.

What I think people need to do, is hold the flex pcb down while you solder, and continue holding it for a couple seconds after you finish the joint. I think people are either soldering it without pressing down, or more likely they let go and then while the blob is still molten it pulls up away from the pcb.

Either way I think a quick tap and a little stir with the soldering iron while holding down the flex circuit will fix it!

1 Like

It could be something like this:

I think what most people are having is the situation on the right where the joint is quickly flooded with a lot of rosin-core solder and the flux is pooling under the connection on the flex joint.

This can seem like physically the joint is connected, and it is… mechanically… but not metal-to-metal chemically.

Yeah I think you’re right @Mr.Blinky and @bateske, must be bad solder on SDA, because I took it apart and removed that metal piece that was floating around and it still gives me the same error when I try to flash it.

BTW I was curious about that small metal piece that was floating around, so I dug up an old picture of my Arduboy from 2016 lol and sure enough I can see it in the old pic (3rd pic with green background), so must have been like this from the factory :thinking:

Anyway, I’ll report back after SDA has been re-soldered. Thanks!

Oh lord it’s the end of the battery tab. Sorry about that.

I’m pretty sure giving the SDA solder the ol’ 1-2 I think it should work.

No worries! And yeah I thought the same when I saw the back side…

Hey guys I just wanted to report back that after re-soldering SDA all is working great! The mod chip is recognized now and I am able to flash it no problem. Thanks again for all your help!

3 Likes

Nice work!

Hello, i have a problem, i’m in a boot loop.
I have the Arduboy Arduventure Trail of the Blade version.
I use the menu and “upload” button, holp the up button. I boot on the FX Activator, flash the mod chip (ok), then flash the bootloader. And now, i’m on a screen with Arduboy (but i just see the hald of the text) and it bootloop. What ca i do ?

(if a try during the loop to hold the up button, i have a white screen but it disapear in 2 seconds, and bootloop again)

ps : the soldering was okay, the status in FX activator was good

If I understand you correctly,

  • you upgraded your Special Edition Arduboy with a blank Mod chip.
  • You successfully uploaded the activator sketch and successfully flashed the Mod chip.
  • You tried to flash the bootloader but it failed and resulted with Arduboy being in a bootloop.

This behaviour indicates a bad solderjoint / connection on the mod chips reset pad.

Open up Arduboy and inspect and reheat / resolder the reset pad.

1 Like

It was not a blank Mod chip. It’s a pre programmed version. But the step with the RST button have no reaction, no boot on the chip. Just reboot the pre charged game.
And in the step 6 of https://arduboy.com/start-fx/ it sayd ’ “his step can also be performed in software by using the FX Activator.” So i try to flash the bootloader.

I will try reheat / resolder tomorrow.