Arduboy FX library

Thanks.

I tried a ‘pip update pillow’ but it says I am already at the latest version.

I will continue googling answers … someone must have found the same problem.

Did you do that from the normal terminal or the version in the arduino tools folder?

If the normal installed version is up to date. Can you locate it’s folder? Maybe you can copy the pillow folder manually into the arduino tools folder.

Try copying the PIL folder from /usr/local/lib/python3.10/site-packages to \sketchbook\tools

I ended up resolving my immediate issue by

  • unistalling all the various Python versions I had on the machine (they breed like rabbits)
  • reinstalling Python3.10.8 with Brew
  • copying the PIL directory into the same folder as you suggested.

This didn’t work the first time. I repeated the process a couple of times with variations - including using pyenv - then trashed it all again and did a basic Brew install. Then for some reason it all worked.

I would have preferred not to have to copy the files into the script directory. It feels like my configuration is missing something as I have never needed to do that previously.

I hate when something starts working but I cannot pinpoint what made it work. Thanks @Mr.Blinky !

2 Likes

Sounds like the same hell I went through before quitting :frowning:

PS - messing about with pyenv (copy&paste from stack overflow) seemed to do more harm than good for me at least…

2 Likes

That’s what I concluded about pyenv too. I guess if you are developing with different versions of Python then it might make sense to persevere with it.

I don’t use Python regularly - in fact I am not a fan of it generally - and really do not know what I am doing when it comes to setting up an environment.

I am just happy its working again. Now I can continue with my PoP remake!

2 Likes