Arduboy Game Loader by TEAM a.r.g

Strange … @delegatevoid got any idea what’s happening here ?

Just tried the version from the website and it worked for me with the included Blob Attack file.

1 Like

It works perfectly on my PC. Thanks! :slight_smile:

I have packed my game Bangi to .arduboy format. Here is the link:

Bangi 1.1:

1 Like

Can’t wait for mac release!

1 Like

Maybe someone here has advice for me. My game (1010) draws the last saved game as the title screen, so I don’t have a bitmap somewhere to use for one. Is there some easy way to generate an image from that?


You can use the Chrome plugin created by @davidperrenoud to take screenshots of your game:

You need to add into your game this line to send the screen buffer to the computer:

Serial.write(arduboy.getBuffer(), 128 * 64 / 8);


I’ll add some logging.

The loader works fine!

You can find my game ArduIndy here:

Well I can actually reproduce the issue but only in release mode, so I’ll have to dig into it this week.

1 Like

Hmm. It doesn’t like the name “1010.arduboy”. It’ll open the file and apparently parse it, but the file never shows up in the games library.

Changing the name to “Tiny-1010.arduboy” works fine.

And if you want it, you can find a copy at

1 Like

I’ve opened a Trello board here:

I took the file renamed it to 1010.arduboy and it showed up. (see screenshot in trello),
Something else must have caused the issue.

Turns out I actually cannot reproduce it. The release folder on this machine didn’t have avrdude.exe
(not my normal build system).

So it’s back to square one.
@crait just a sanity check but can you verify that in the directory you got from the extracted download,
you can find

  • ArduboyGameLoader-b17.exe (or whatever @JO3RI called it for that release)
  • avrdude.conf
  • avrdude.exe
  • libusb0.dll

Side note: In the future we’ll provided the app as a sandboxed application with auto update capabilities to prevent
any directory/deployment issues.

I’ve uploaded a new version which adds some logging (local only, does not send data anywhere)

Download here
The SHA1 checksum for the file a832e2284b22196749e7d5a26eaf74960a94a4c2

(Always check the checksum for anything you download,
never trust a checksum hosted on the same server as the download)

If you guys run into issues, feel free to zip (bzip2, 7z, whatever…) the logs and attach them here
or better yet, to the trello board.

A great page for info about how to make the hex-file for the .arduboy-file:

Cheers Jacoste

1 Like

I can’t get it to detect my Arduboy, it just says Arduino not found. Arduino IDE detects it just fine on COM5. I have used other cables and usb ports but it just refuses to detect it for some reason.

Would you mind trying the latest version, that one generates log files.
Those logs could be interesting for us to figure out what’s going on.

For the next release we added support for both the official Arduino drivers
as well as support for native Windows drivers (ie. detect the Arduboy without anything Arduino related installed)
but no release date yet.

After rebooting my computer the Game Loader does recoginize the arduboy and reboots it into the bootloader, but after that nothing happens, it closes the grey window saying that it has found and is rebooting the device. Once the arduboy reboots it still has the previous game. Here is the log file

2017-01-20 10:51:50.6546 INFO Copying C:\Users\shash\Downloads\gameloader-latest\tmp\tmpAEFE.hex to C:\Users\shash\Downloads\gameloader-latest\tmp\opvbviwh.hex
2017-01-20 10:54:20.2417 INFO Copying C:\Users\shash\Downloads\gameloader-latest\tmp\tmpFAE3.hex to C:\Users\shash\Downloads\gameloader-latest\tmp\nowlhhlw.hex
2017-01-20 10:57:22.9133 INFO Copying C:\Users\shash\Downloads\gameloader-latest\tmp\tmpC474.hex to C:\Users\shash\Downloads\gameloader-latest\tmp\1ni4ro5l.hex
2017-01-20 10:58:13.7593 INFO Copying C:\Users\shash\Downloads\gameloader-latest\tmp\tmp8B11.hex to C:\Users\shash\Downloads\gameloader-latest\tmp\dinlj1m0.hex

Your system specs might also be helpful. I’ve had all sorts of issues trying to get anything Arduino related to work on my Surface Pro 3 for example.

Interesting, I’m using a Surface Pro 1. What issues where you having and where you able to solve them? I wonder if it is something about Surface devices or just a coincidence.