Arduboy Gamepad - Map buttons to keys!

(Kevin) #3

shhhhh… :zipper_mouth:

1 Like

(Holmes) #4

This is absolutely brilliant! Amazing work, dude! I love the idea and love that you can save the inputs! Can’t wait to load this up on my Arduboy whenever I get it in. :smiley:


(Ross) #5

You know everyone can still view the edit anyway right?

This is a public discussion, if a user wants to mention a product it won’t hurt anything on any level. So the edit is just odd here.



I think they understand and are just having fun with the forum software :grin:

1 Like

(Ross) #7

One can only hope :smiley:

1 Like

(Leo) #8

Well out of the last two Kickstarter backings I’ve done arduboy is my favorite…

So I decided to combine the two! Lol I was bored😜


(Sebastian Perez Galarza) #9

upload code!!! upload code!!! XD


(Leo) #10

The pocket chip was set up following this, with some tweeks…

The arduboy is the same code posted in the first post of this topic, no change.


(Holmes) #11

I just tried this out and it’s as amazing as I thought it would be! Great job, @fuopy!


(Jezzamon) #12

This is great! I was just about to program something like this myself out of curiosity to see whether it was possible. I now know it is, and not only that, but you’ve made something much better than I would have!

One issue: The labels for the A and B buttons seem to be backwards. This one seems to use the gameboy conventions, whereas the buttons are named differently on the Arduboy.

1 Like

(Mattia Colasanto) #13

Hello, Guys.
Today, 20th December 2016 i have uploaded Arduboy Gamepad Sketch to test it.
When i have uploaded it i noticed that it doesn’t work well.
After i have installed ArduSnake to test it , I realized that was not working the key A_BUTTON :frowning:

What i have tried :

Disassembled Arduboy to test hardware;
What i think is the problem :

When I was hacking with Arduboy Gamepad I “accidentally” modified settings by assigning anything to A_BUTTON and now I do not know how to restore it :frowning: Help me please …

-P3RISH (Mattia Colasanto);


(Kevin) #14

@P3RISH it might be better to start a new thread, because if you upload new software, all of the device settings are reset. The only way to cause a problem that will persist between uploading new games is if you modified the library. And if you did that, and are concerned about the edits to the library, you can always re-download the library.

Last but not least it is possible there is a mechanical issue with the A button as well.

1 Like

(Jezzamon) #15

Worth noting to future users: There’s a bug with this tool. I’ve submitted a pull request to fix it but fuopy hasn’t accepted it yet… it’s been a while. :confused:


(Kyran Bullard) #16

Any chance on a .hex or .arduboy file?


(Erwin) #17


(Kyran Bullard) #18

Awesome!! I just got everything I was looking for in that link. THANK YOU!!

1 Like

(Kyran Bullard) #19

Where is the enter button on the gamepad?



the Arduino IDE code has an error

#include “globals.h”

ArduboyGamepad:1:21: error: globals.h: No such file or directory

compilation terminated.

exit status 1
globals.h: No such file or directory


(Simon) #22

When you downloaded the code and opened the .ino file in the IDE, did it come up with a warning that the name of the file and containing directory did not match? And, if so, did you let the IDE move it? If so, the IDE moves only the .ino file and none of its dependencies.

Step 2 Rename the extracted “ArduboyGamepad-master” folder to “ArduboyGamepad” fixes this issue.


(Pharap) split this topic #23

A post was split to a new topic: Arduboy + LUFA + Splatmeme Printer - Is it possible?