Arduboy Help Please OLED Display Problem and Boost Converter

So my teacher has given me the task of building a new Arduboy with an Arduino Leonardo, we had a previous one but got new ones that are much better,<There was stuff here but I realised I big stinky and put the converter the wrong way ¯ _(ツ)_/¯ >. My Second problem has an image attached where I upload a piece of code (Mini City for the Arduboy) and the screen flickers weirdly, any help with this? I also had to remove the converter so the display would show


(P.S. the top part has lines that run through, and the lower part is just full white)

Sure you picked the correct display? Just had that yesterday when i uploaded a sketch with ssd1306 selected but mine is a sh1106 display.

1 Like

Oh my god yes, mine is a sh1106 too, do I have to change the display?

no not at all :wink: You will need @Mr.Blinky Homemade Arduboy Package and select the proper display to compile abd upload a game. The original .hex files will not work out of the box. I think there is also a converter somewhere.

Here the link:

2 Likes

Thank you so much, I will let my teacher know about this in the case this happens for the other displays (That is if he doesn’t have to keep stopping for the annoying kids and takes forever to get through it all lol)

I loaded the home made package and the fuzzy block is still in the bottom, what do I do about that?

You will have to deinstall all original Arduboy libraries first. @Mr.Blinky gave me a genius hint:

You can use the zip Version of Arduino IDE as portable Version:

Download the Arduino IDE zip pack (not the installer)
and unzip somewhere. put a blank folder “portable” in the folder of the Arduino IDE and then start it.

then you will have a fresh portable version where you can install the homemade package and retry.

For upload you will have to select:

Homemade Arduboy

and then:

Your board (Leonard if i got it right)
Standard core
SH1106 display
original bootloader
the recommended flash select
and the correct port or course

I don’t know how to uninstall the libraries, I made a folder with the new application of Arduino in it with a portable folder but it still just loads the original arduboy libraries

Sorry, maybe it is a special download of Arduino IDE. Here the link that worked for me:

https://www.arduino.cc/en/Guide/PortableIDE

I got it working, had to remove the Arduino15 folder from /Users/home/Library

Edit: partially

I was able to remove the libraries and tried loading Micro City for it, shows a part of the menu and still that fuzzy block

Well i had another issue with my Homemade, not sure if valid for yours also:

I connected the buttons wrong… It should be going to ground. I had them going to 5V. So not sure how yours is set up. My screen just stayed white because of this.

Here’s an image of my setup

Well it is not how you soldered it but how the schematic of the board is. Can you see if the buttons are connected to ground or 5V ? I normally set up my buttons different that is why i had to change unexpected

It looks like they connect to A0,A1,A2 and A3. There’s nothing I can do to change this though

yes that is correct. and the other end of the buttons? where do they go? plus or minus?

I don’t know if you’re referring to the other pins on Left,right,up,down or the right side with SW_A and B, A and B go to 7 and 8

All buttons are set up like this:

they have 2 pins that are not connected to each other, only while pressing. In the Arsuboy one side of this pins goes to either A1 A2 etc and the other side goes to minus.

if this device has the buttons connected to plus it would cause problems…

I have an image of the board before it was setup the lines are from Fusion 360 because I deleted the original image

@mameise I found the originals, front and back