Arduboy is not detected

The site appears to be down now. I can’t find another reasonable uploader for the Arduboy that works. Looks like I have a pocket-sized paper-weight. Super pissed.

Have you tried ArduManFX? It’s still a bit of a work in progress (as it’s intended to be usable for the upcoming ArduboyFX) but it’s also able to upload games to regular Arduboy’s as well. Currently it only supports uploading games from @eried’s repo though. As a bonus if you’re having trouble uploading a game (because the one that’s loaded requires some specialty steps that you can’t quite figure out how to get right), there’s a recover button that once activated just requires pressing the reset button on your Arduboy at any time and it’ll upload a basic sketch allowing you to upload a different game.

1 Like

I believe @crait’s website got hacked hence you cannot download this.

Quite frankly though, saying Looks like I have a pocket-sized paper-weight. Super pissed. doesn’t make me want to rush out to help you though.


If you were looking for Arduboy Manager to save you then you are probably experiencing some other issue? What’s the problem with your arduboy you should try making a new thread or writing to Contact — Arduboy we can for sure help from there.

1 Like

You could always install the Arduino IDE and compile your games from source.

1 Like

What about New unofficial Arduboy Uploader :) ?


My issue appears to be computer recognition. I’ve tried 7 different cables, and neither my desktop nor laptop can detect the Arduboy. Contacts are clean, it’s been well taken care of. No idea what to do at this point.

What game is on the device at the moment?

Some games drop the USB code to make extra space for the game itself. @tuxinator2009 ArduManFX is the easiest tool to get around this. Give it a look if you haven’t already.


Have you tried the reset dance:

If none of these methods work please write to Contact — Arduboy and I can try to help from there.

1 Like

Have you double-checked the drivers? You could try uninstalling them and re-installing them.

I think it’s about time we started maintaining a list of the games that do this.


Ok, I’ll start …

Nearly all PPOT games.


I have Arduventure installed, which I know causes a lot of problems. I tried the fixes recommended by the YouTube videos, but my computer recognizes the device for less than a second. Not enough time for Arduino to do anything, even when timed right. Any idea what to do now?

For Arduventure you need to select “Upload” from the menu and when prompted press and hold the down button (instructions provided in the “Upload” menu). Do not let go of that button until a new game has been uploaded. That’s why it’s picking it up but only for a split second is it’s going into bootloader mode then exiting out too quickly. By holding the down button down you’ll force it to stay in bootloader mode until it receives the exit bootloader command from the computer or you let go of the down button.

1 Like

I tried that, and it didn’t work.

Are you using Arduino to perform the upload?

It’s best if you start the upload so that you can see the terminal window repeatedly looking for the com port, then when it’s doing that do the restart.

If you’re still having problems please write into and either I can try to directly help you from there or if you want to send it in I’d be happy to fix it for you too.

I am using Arduino, yes. It tries, then says cannot find a board on the selected port. But it wont let me select a port anyway.

Let me know, I can try to fix it for you!

Just a thought: how old is your Arduboy?

Probably old enough to potentially have a corrupted bootloader.