Arduboy loses connectivity to windows 10 [Solved]


(Tiago Aston) #1

Hey guys
So, i just got my Arduboy a couple days ago. It was great out of the box, no issues uploading game what so ever.
But this morning i tried to upload a code from the example sketches that come with the libraries intalled on to the arduino IDE. I uploaded “PlayTune” and suddenly, nothing… black screen…
Unplugged it, re-plugged, reset it, all that jazz. Yet nothing seems to work. It does, however, light up the red LED neãr the micro usb.
The oddest part is that if i plug it in and rest it through the small button, it shows up, but only for about 10 seconds…

Can someone give me a hand here?
Thanks :stuck_out_tongue:


(Kevin) #2

It’s possible this sketch is not compatible with the current Arduboy hardware? Or that nothing is on the screen.

Are you able to reprogram it now? Try going back to a sketch that worked before.

If the Arduboy doesn’t automatically reprogram with Arduino you will need to time it so that you press the reset button during the “uploading…” phase of the arduino upload.


(Tiago Aston) #3

The issue is that it only stays connected for 10 seconds. But in that time, neither the IDE or the arduboy game loader detect it. It shows up in device manager, but only for that short time window, after i press the reset button. (so i plug it in, turn it on, press the reset button (otherwise windows doesn’t detect it). It’s picked up by the pc and then lost after 10 seconds)
So i can’t reprogram it or even interact with it through the pc. All i get is a black screen on the arduboy.


(Scott) #4

Have you tried flashlight mode?
http://community.arduboy.com/t/how-to-use-flashlight-mode-to-fix-bricked-arduboys/2326


(Tiago Aston) #5

Just tested it, but no luck


(Scott) #6

Sounds like your last upload failed to complete properly. The reset button may be your only hope.

It’s very tricky and a real pain. I’ve sometimes had to try dozens of times to get the timing just right, the few times I’ve had to use it.


(Tiago Aston) #7

What do i have to do?


(Scott) #8

Open a simple sketch such as the HelloWorld example. Make sure you’ve selected Arduboy or Arduino Leonardo as the board type. Verify the sketch using the checkmark icon.

  • Start your upload.
  • Press the reset button.
  • Cross your fingers.
  • Repeat until success.

Maybe also try pressing reset before starting the upload. Vary the time between starting the upload and pressing reset. You may find that the Arduboy has moved to a different port and you may have to change the setting in the IDE.

Good luck.


Usb games loader
(Tiago Aston) #9

Ayyyyyyyyyyyyyy its working xD
I managed to pull it off in a couple tries
Thank you so much Scott :smiley:


(Kevin) #10

The trick is to watch the status bar in the bottom left corner that will say “Uploading…”

You’ll actually want to press the reset slightly before seeing this, but it will also work if you immediately press the reset button at that time, since the PC will actually retry a few times to initiate the upload.

Glad to hear you are back up and running!