Arduboy Manager 2.0 Released!


(Scott R) #59

If you change your Pro Micro bootloader to the Leonardo Caterina one the app will detect it.


#60

won’t that cause any issues since i am installing a bootloader meant for another board?


#61

If you need any information about this board, feel free to ask :slight_smile:
I really hope support for the Arduino Micro will be a thing!


(Scott R) #62

I’m using the Leonardo bootloader on a Pro Micro I would assume since the micro also uses the 32u4 it would be compatible with maybe more pins exposed than a pro micro.

The only minor issue I have with the pro micro is TX/RX LED are reversed.

I think @MLXXXp posted the pin outs for both the micro and pro micro in the $12 Arduboy topic where you could compare.


#63

How do you mean “reversed”?
As in the TX light now means RX and the RX light now means TX or the RX and TX light are always on until you send serial data?
And also, if i want to replace the bootloader with the Leonardo bootloader. Do i have too select the Leonardo board in the Arduino IDE and then flash the bootloader onto the Micro?


(Scott R) #64

Pro micro bootloader has them active HIGH and leonardo bootloader has active LOW.
when flashed with Leonardo bootloader behaviour is same as on arduboy.


(Scott) #65

The TX and RX LEDs on the Arduino Micro (not the SparkFun Pro Micro), have their common pins wired to ground, so setting the pin HIGH will turn it on. The Arduboy, Arduino Leonardo and the SparkFun Pro Micro have the commons to VCC, so you set the pin LOW to turn it on.

With a sketch or bootloader that directly controls the TX and RX LEDs, intended for a Leonardo but loaded into a Micro, each LED will be on when it should be off or vice versa.


(Scott R) #66

Aha so my clone Pro micro I transplanted had the Micro bootloader, I just thought this was a Pro Micro thing as the first thing I did with my other Pro Micro was to burn Leonardo Caterina on it but that one ended up in a clone and I forgot to burn the new one before transplanting it.


(Mingye Wang) #67

Running Arduboy Manager 1.2.5 on Windows 10 (17074). It seems to stall a lot independent of whether the device is plugged in; not even the window buttons work. Where can I download the new 2.25 thing?

When I analyze the wait chain in task manager, it seems to be waiting for a specific instance of svchost running the Winmgmt service. When I terminate that process, Arduboy Manager would show a .NET error window to complain about a failed remote procedure call. The error window is a bit more responsive than Arduboy Manager itself, but still feels pretty “stuck”. The error does not stop the main program from staying stuck as another wait would soon start. Sounds like the “check for device” version of putting the netcode in the main thread?\


By triggering the error I seem able to isolate the action for which the RPC was taking place. The call stack looks like:

<strange windows stuff>
AM2.F1.GetUSBDevices
AM2.F1.setport
AM2.F1.checkforarduboy
AM2.F1.timer1_Tick
<strange stuff for calling the timer>

GetUSBDevices uses a certain ManagementObjectSearcher to look for serial devices; the name seems to fit that service in question pretty well. Although the searcher itself is perfectly async, the immediate use afterwards mandates the wait and makes the entire “tick” procedure blocking. And on top of all that the WinForms timer indeed runs on the UI thread.


(Dave) #68

ok question since its been over a year since i last grabbed a hex file of any of my games. step me trough the proccess of how to get the hex file from my computer and convert it into an .arduboy formt file please. i have something i want to release :wink:


(Holmes) #69

No need to convert a .HEX to a .ARDUBOY . This program can handle both. :slight_smile: However, if you’re asking about making your own .ARDUBOY file, you may want to check out this thread . It’s essentially a .ZIP file with the .HEX files inside.


(Dave) #70

got it thanks
about to post new arduboy file :slight_smile:


(flybat3) #71

having the exact same problem. Probably going to go back to version 1 honestly.


(Holmes) #72

I have heard several reports of this. I am thinking that this is stemming from a recent change coming from a Windows driver update for some computers. I’m trying to pinpoint a work-around.


#73

@crait
I like what you put together. (although it seems like the scrolling direction is inversed)
Nah. It’s just the rolling…thingy. ignore what I said.

Hey, uh … your Arduboy Manager (latest version) cannot detect my Arduboy (seems like it is running though all the serial port, my arduboy’s GREEN LED(Rx/Tx lights) is flashing every … 2 second or so.) Ran the as administrator on Windows 10.

I bet there is no problem over the driver thingy (my system see it as a COM port, and Arduino IDE also see it fine), and since that, my cable is good. Tried using Arduboy and Arduboy2 library, including Serial.begin(9600);, and as many ideas as I came up with, plus the reset button and flash light mode. Nothing worked.
Hmmm…
I want to mirror my Arduboy screen to make a video of SOMETHING…
Hello? @crait ?


#74

@crait
Are there any plans for supporting the Arduino Micro bootloader? like maybe as a setting where it changes the way it transfers the game. Since my Arduino Micro is for some reason unable to be flashed to the leonardo bootloader (no programmers detects it, Arduino as ISP and a dedicated programmer that i own)
the board just doesn’t talk to the programmer and i would really love for this program to work with my DIY Arduboy :confused:


#75

@CrazyVito11
If it is a Arduino Micro (with the ISCP header and the big red reset button), then it don’t mind whether you flash it with Arduino Leonardo or Arduino Micro, and if you flash it with Arduino Leonardo, it should recognize it as a Arduboy.
But if it is one of those Pro Micro (without the ISCP header and no reset button) then maybe you need to do one thing and another.

Arduino Leonardo, Arduino Micro, Arduboy and Lilypad all use the same MEGA32U4 processor. Pro Micro seem to do it slightly differently, though.

And yes, if Arduboy manager can’t recognize things (even the original Arduboy), then Hmmm…IDK but I also had this issue (where I can’t get my Arduboy detected)


@crait






These are the ones I can hand out, currently. May need to update one thing or the other, but…that’s it for now.
Can you add these games to your repository? Thanks.


#76

I already configured it as an Arduino Leonardo, the arduino ide detects it as an Arduino Leonardo. But that doesn’t mean the bootloader is the same.
The Arduboy Manager detects it as an Arduino Leonardo, but it can’t flash it because the Micro uses a different bootloader than the Leonardo. (and yes I already tried flashing the Leonardo bootloader onto it, but the chip just refuses to connect to the programmer)


#77

Interesting…
Did you tried to burn the bootloader (via ISCP)?


#78

Yeah i tried, but the microcontroller refuses to talk to any programmers i tried (I connected it correctly and tried multiple times, trust me, it just doesn’t work for some reason)