Arduboy Mate repositories problem

Hello
I have a problem with the repositories in arduboy mate my phone is Huawei p smart version of android 9.0 problem is that when I type in the repositories I get “Repository data request failed” even when I add the default repository http://mockfrog.de/arduboy/repo.json I get the same error.

Please answer me.

Usually mine works, however I’m having this issue right now too. The only one that’s working for me is http://arduboy.ried.cl/repo.json (@eried’s repo, which is very full and may be all you need)

You should also try https://play.google.com/store/apps/details?id=com.obnsoft.arduboyutil

Hello,

I got the same problem. I installed Arduboy Mate on my smartphone with Android Oxygen 9.0.11. But I got error: “Repository Data Request Failed” when I tried add both mockfrog or arduboy,ried repositories. I have a connection on my mobile. Repository seems working in the browser. I tried also on my older phone with different version of Android, still can’t add repository. Anyone have any idea?

Who made the mate I can’t remember but that sounds like their hosting server just isn’t there.

“mockfrog” according to GooglePlay.
I would assume they hold the account named @mockfrog.

@mockfrog was last seen “Dec 14, '17”,
so I’m not sure there’s much chance of this issue being fixed.

It seems that only the creator can answer that.
The software doesn’t appear to be open source,
or have a publicly accessible source code repository.

Hi Kevin,
I’m the creator of this app. But I must admit I have not touched it for a long time. The repository it looks for as default is the one from @crait at http://www.crait.net/arduboy/repo2.json which seems to be gone.

1 Like

He just did stuff to his website so he probably moved it. Yo @crait buddy help us out.

Thanks @mockfrog!

1 Like

Actually, what happened is that my website was hacked by a bot that scans for common security vulnerabilities. I ended up losing a bit of my server data, including the Arduboy repository I was maintaining. For now, you can find a lot of the same games using this link from @eried. https://arduboy.ried.cl/repo.json

Maybe I could get in touch with him and have him host Circuit Dude and my other games, too? :thinking:

1 Like

Anyone with a GitHub account can make a PR to the repo:

1 Like