Arduboy not holding a charge!

I received my Arduboy today and I’ve been uploading a few games and demos onto it to try them out but I went to take it out with me and the board doesn’t hold a charge at all. It works fine when plugged in but as soon as it’s unplugged it lasts maybe 30 seconds max and then goes to a black screen. I’ve tried resetting the device and nothing seems to work.

Can anyone give me some help??
Thanks in advance!

Could you try leaving it plugged in overnight? : ) Or maybe you already a have? Has the Arduboy been plugged in for a few hours without being used yet?

It’s been plugged in for a couple of hours now but I can leave it in overnight just to make sure.

Sure, it can’t hurt to charge it a bit more. Did you try any other usb cables? (who knows)

There is one DIY option for one of those “maybe it’s something simple” situations. If you are feeling brave, you could grab a correctly sized phillips, a #1 bit might do it, and carefully take out the screws on the back plate of your Arduboy and inspect the circuit board, battery and connections to the battery.

If you take the unit apart and look at the back, it should look something like the image below.

Notice on the top of the unit the two solder points for the battery? They are labeled (+)BAT and (-)BAT on the circuit board and are the positive and negative connections for the battery. It can’t hurt to take a look at these two connections and see if it’s perhaps a bad or damaged solder keeping the battery from being charged.

It also never hurts to take a picture of your naked Arduboy and post it for the electrical engineering types to take a look at and maybe spot a defect.

https://pbs.twimg.com/media/CiE3o-OUUAE5LVH.jpg

An image of an Arduboy PCB (back), battery and faceplate.
https://twitter.com/ArduboyTweets/status/729925792981876736

That’s just something to do if you are interested in that. Otherwise, go ahead and charge it a while longer, maybe not overnight, but a few more hours, flip the switch a few times and let us know if there is any change.

If you have a multimeter, it’s also possible to test some other things. Anyway, that’s above and beyond.

:heavy_check_mark: I’ll leave the issue open and forward it on to @bateske and @Celinebins. If the unit ends up not taking a charge, we will get a new one to you.

I’ve tried 3 different usb cables and also used different plugs as well as my desktop USB ports and nothing has worked. As of now I’ve had the arduboy charging for about 3 hours, I unplugged it and tried to turn it on however it instantly powered off again.
Here is a photo of my unit and I can’t tell any differences between this one and the one in the tweet. In the morning I can try and reheat the solder to see if that could help it in anyway but from what I can see the solder seems to be fine.

When the unit is plugged into the usb cable it works fine but the moment it has been unplugged it powers off almost immediately.

You could try putting a multimeter across the battery terminals and see if it’s holding a charge. Check both the volts and amps. A fully charged LiPo should be around 3.7v - 4v, a flat one will be around 3.2v or less.

You could also check whilst it’s plugged in and charging too. That might give you an idea of whether power is reaching the battery terminals.

1 Like

Notes on Soldering to Lithium-ion Batteries

Just for reference :wink:

Don’t reflow any bad solder on battery leads please :exclamation:

  :boom: Risk of explosion :boom:

###Proof.

The battery terminal solder joints look fine to me. Nice and shiny with good meniscus curves.

Ah, yeah I see, I saw the dark reflection as a giant hole. Disregard my previous post, I’ll edit it out. Thanks @MLXXXp, for the 100th time.

I had to look up what a solder meniscus was :smile:.

solder meniscus


The excellent solderability of Pb-Sn solders is a result of their good wetting and spreading
properties [5]. Wettability is the capacity of a molten solder to react with the base metal at their
mutual interface and establish a bond. ln the Pb—Sn system. the interface reaction is typically
between Sn and the base metal. in the form of an intermetallic compound layer. Spontaneous
spreading of molten solder over a horizontal surface ends with the sessile drop profile. On the
other hand. spontaneous spreading on a vertical surface results in a meniscus. which then
solidifies into a solder fillet. Good spneadability allows molten Pb-Sn solders to cover a base
metal surface without necessarily having to be placed over that entire surface. Lead~tin solders
also exhibit good solderability in closed solder joint geometries such as gaps and holes. The
spontaneous filling of through-hole solder joints is assisted by capillary flow.

 - books.google.com

I wish @bateske would get around to publishing the complete schematics. I might be able to be more help with this sort of thing if I knew the power circuitry.

1 Like

Sometimes I run (clandestine) operations. I’ll see what I can find out when I see him at Maker Faire.

You can’t check amps without desoldering one of the battery leads. Never put a meter in amps mode directly across the battery terminals!! The meter will short out the battery and likely blow a fuse in the meter or damage it, or damage the battery, or cause a fire.

Would suggest carefully lifting battery up, to see if the solder joints on the piezo (disc ‘speaker’) have punctured or damaged the battery. This wouldn’t be visible from the front.

I have looked at trying to lift up the battery however this seems impossible with out desoldering the 2 red wires which (I think) go to the piezo and the speaker seems to be hot glued onto the battery?? Is this normal and if so what do I do?If this isn’t normal again what should I do?
Also I charged it overnight and the battery hasn’t held any charge.

I will definitely not touch the solder near the battery then. Thank you for saying so before I blow something up :fearful:

I guess I forgot to mention it in my last message but I don’t have access to a multimeter so I unfortunately have no way of checking voltage. I know right some hobbyist I am :stuck_out_tongue:

1 Like

Yeah, haha you bought a product for it to work, not for you to have to make it work : P

Could you pm me your address and email, I will get a new unit out to you.

I have the same problem. Charged ALL NIGHT, still doesn’t hold a charge for more then 5 seconds.

When I first plug it in the red charge light shows constant for like a minute or less, then starts randomly flashing a non consistent pattern, like the charging circuit is totally messed up. This has ONLY been plugged into my PC (USB 2.0 port) and a iPhone charger (for the all night charge) [AFTER the PC charge wasn’t working].

This is a (1 of 10,000) kickstarter edition. Everything else is great other then this.

Ahhh, sorry to hear, please use the https://www.arduboy.com/store/contact-us page to see about a replacement. This applies to anyone who is having similar issues. If we are able to get one of these units, we may be able to discover what is either the defect in the units, or what can be done as a user to properly operate the unit.

Either way, if there is a defect in the circuit for charging or with the battery, then we are happy to get a working unit out to you of course!

1 Like

K sent message, let me know if you would like any pictures and or video from inside my device as well, if you think it would help. I could post a video of the odd flashing charge light etc

1 Like