Arduboy not recognised by PC [Solved]

Hello, I’m new here, and I’m very desperate for help. My arduboy came in the mail today, and works fantastic with the game it came preinstalled with. However, when I tried to install new games, my computer and the arduino software won’t recognize my device. It will charge, but nothing else. First thing I did was immediately report here to the forum and see if anyone else had this issue, which many have, and I took the advice that all the posts said. To try a new cord. Well, I’ve tried about 5, and nothing has worked. So I started thinking maybe it’s my computer. But then I went through and tried all of the cords with my cellphone, and my computer immediately recognizes that a new device has been plugged in, eliminating both the cords and the computer being the issue. I’m a complete noob here and would appreciate any help whatsoever. Thanks

Does the yellow led light up at the bottom of the Arduboy when you plug it in with the power on? You should hear a USB-Connected sound from windows when you plug it in.

Are you familiar enough with windows to open the device manager and see if it shows up under usb devices?

The yellow light doesn’t come on, no usb connected noise, and won’t show up in device manager either

Hmm, sorry to hear this! Can you write us at arduboy.com/contact and we can try to assist you directly from there. Thanks for letting us know!

Do any lights light up at all when you plugin in?
Mainly the red charge indicator.

I ask because I’ve found I have one that I use less with a slightly tight port that needs an extra little push to make a proper connection.

The red light does indeed come on

OK are you turning the Arduboy on when connecting?

Sure am, I make sure it’s powered on every time I’ve plugged it in

1 Like

I’m assuming you’re using a Windows based PC. Check if you’ve got an unknown or other device with a yellow exclamation mark in device menagement.

Check device manager

  • On Windows 8 and up: press Windows key + X and select device manager or…
  • on all Windows, press Windows key + R then type devmgmt.msc and press enter to go to device manager:

In this example it is identidied as Arduino Leonardo but it could be something else to. What’s more important is that it has a valid USB VID (Vendor ID) and PID (Product ID). you can check this out by

  • rightclicking the device with exclamation mark
  • click properties
  • select details tab
  • in the properties dropdown menu select Hardware Ids

you should see something like this:

  • When Arduboy is in bootloader mode it should start with USB\VID_2341&PID_0036
  • When Arduboy is in normal (application) mode it should start with USB\VID_2341&PID_8036

VID & PID match

You need to install the driver. You can do this as following:

  • Right click the device again and choose Update driver
  • click Browse my computer for driver software
  • click the browse button and browse to your Arduino (installation) folder, select the drivers folder and click OK.
  • Make sure the option Include subfolders is checked and click Next
  • The driver should be installed now and you can close the window

VID and PID are different:

When the VID and PID are both zero or other values. Arduboy is unresponsive. This could be due to a bad or broken cable. A malfunctioning USB port or if you’re using an USB hub/adapter, a malfunctioning hub/adapter. There’s also a chance that the sketch or bootloader got corrupted after uploading a bad or too large sketch.

Things to try:

  • Turn Arduboy on (switch to right position)
  • Make sure the cable is proberly inserted at both sides.
  • Restart your computer (Yes it sounds silly but you don’t know how many problems this can fix)
  • Open device manager to see if a port is added under ports or if there is any activity when you try the following steps:
  • try different USB port
  • If you have a different USB cable try that one.
  • if you’r using an USB adapter, try a different one.
  • press the small reset button left from the USB port on Arduboy and see if a port (briefly) pops up in device manager.

If you see a port pop up briefly in device manager. Make a note of the port number and start up the Arduino IDE

  • Select the blink example sketch (File > Examples > 01.Basics > Blink)
  • Go to tools > board menu and select Arduino Leonardo
  • Go to tools > port and select the port.

If the port is grayed out in tools or the port number is not selectable. Press the reset button again, wait 2 seconds and try to select the port again.

After you’ve managed to select the port. press the reset button again and press the upload button immidiately. If the Rx and Tx LEDs on the Arduboy don’t start flashing within 5 seconds press the reset button again.

Are you using the cable that came with the Arduboy or a different USB cable?


Sometimes manufacturers make USB cables that can only provide power and don’t facilitate data transfer.
(Which technically breaks the USB specification/standard and means they shouldn’t really be advertised as ‘USB compliant’.)

The user did mention he has tried different USB cables, ones that are able to make a data connection to the cell phone so that’s likely not the issue. It would be interesting to see what device manager yields.

@LieutenantToaster if you’re able to do the check @Mr.Blinky suggests let us know the results.

1 Like

Sorry, I missed that part.

Good news today guys! Everything that was suggested didn’t change anything, nothing at all worked. I even resorted to completely resetting my laptop. Even after that, nothing was working. I went into device manager and noticed that a ton of errors had shown themselves that were not ther before, so I deleted all the driver software that had anything to do with any ports whatsoever, restarted my computer, and it started working! Was able to download castleboy, and I’m thoroughly enjoying it. Thanks so much for the help everyone!!!

2 Likes

Nice work @LieutenantToaster! Persistence has paid off!

2 Likes

HI,
i’m having the same problem.
Tried with different cables, tried also with different computers. Result: only the red light turning on.

I tried pushing the reset button on the Arduboy, having it linked to the PC, and when I do it I hear the sound of the USB connected, but when the arduboy restarts I hear the sound of the USB disconnected. If I check the device manager I can see for some seconds (when the arduboy is restarting) the Arduino Leonardo PORT 8 but then, when the arduboy is again on, it disappears.

Please, can you help me?
Thanks
L

Maybe using your method @Mr.Blinky I was almost able to upload some new game, but the problem now is that I have arduventure on it and it needs a specific method to upload another game.

Hello for Arduventure you’ll have to follow this guide:

You’ll need to hold up while on the upload screen, and continue to hold up until the program has flashed.

Hi Kevin, thanks I already knew that guide and maybe it was Arduventure that gave me problems with the “identification” of the USB on the PC.

I now managed (dunno how) to install Mystic Balloon, and when i plug the arduboy on the pc it is connected (yellow light flashing). But when I try to change to Squario I’m having problems with the uploading. I tried also with another game and it keeps telling me:

flappyhalloween:13:21: error: Arduboy.h: No such file or directory
compilation terminated.
exit status 1
Arduboy.h: No such file or directory

The board and port are set in the right mode.
And the Arduboy game loader WORKS perfectly (i tried with another team arg game and it works). It is the ARDUINO program that doesn’t work maybe?

That’s a compilation error, not an upload error.

That means the game uses the old Arduboy library and you don’t have the old library installed.
Use the Arduino IDE’s library searcher (which presumably you used to install Arduboy2 to compile other games) to find “Arduboy”.

If you haven’t managed to compile other games on the Arduino IDE, perhaps you haven’t installed the other libraries either?

Compiling and uploading source code is a slightly different process to just flashing a .hex with a ‘game uploader’.

If you haven’t instaleld a library before, see here:
https://www.arduino.cc/en/Guide/Libraries#toc2