Arduboy not recognized by... anything

I got my Arduboy today and the excitement soon wore off after a few hours of painfully trying to hook it up to the PC and send anything to it from the IDE.

I followed the Quick Start Guide (several times) but still nothing. I also tried 3 USB cables with varying success. The one I regularly use on my phone to transfer files, pictures etc doesn’t make the Arduboy red LED light up. 2 others do make this happen but I suspect they are charge only. I tried 4 USB ports on a Windows 7 machine and 2 ports on a Vista machine.

In the IDE I do see the boards listed (Arduboy, Arduboy Devkit and Arduino Leandro) but the ports section is the issue. On the Win 7 machine I only see Port->Com1. the Serial Ports entry is greyed out. On the Vista machine I dont even get that - the Port menu is greyed out completely.

Nothing is showing up in either device managers. I uninstalled and reinstalled the IDE / drivers a couple times.

Any ideas how to remedy this? I have googled this issue all afternoon and none of the suggestions help. It seems I have a pretty major issue here - maybe a defective Arduboy?

Any advice would be greatly appreciated.

So the unit turns on correct? Sorry about the trouble.

Define varying success? It sounds like these may be older cables. Ones for your phone break pretty quick.

I really recommend going out and buying a new data cable if you have results that don’t seem to be consistent when testing new cables.

If the unit turns on, try a new cable. It’s a bit of a pain it’s turning out, this cable thing, because micro-usbs do break down around the terminal ends so often. But packing one with the unit ups the cost. Anyway, if you can try a new cable, let us know what happens, or PM if it’s possible to pursue that options.

Thanks :smiley:, we will get you going ASAP

It turns on and plays the built in game. The data cable I use is very high quality, gold connectors, works perfectly for every device and charges phones super quick so I doubt that is the problem. The other 2 are lesser quality but one is brand new (came with an external power brick - but could be charge only). I can try to grab a new cable but not sure when I will get time to do that, hopefully later in the week.

1 Like

Sorry about this, it’s worth testing. It’s probably the first test I would do myself. If you would like to PM your address I can order a cable and have it shipped to you for quicker turn around on the troubleshooting task. That will be quicker than swapping out units with us as well (if the cord fixes it) :slight_smile:

1 Like

Errrr…where is the PM link? Sorry, new to this forum!

Ciick on @ekem’s icon or name above then choose Message in the pop-up window.

1 Like

No worries @retroshaun

Actually, you have to be a basic member to send new PMs, but you can also respond to the first message that you are sent by me as a new user.

Either way I have upgraded your account (the forum has many options, and I forget them all the time) so that you should be able to send anyone a message.

Thanks! I figured it was a user level issue :slight_smile:

1 Like

Fixed! Yes, a cable issue. Its crazy how unreliable these things are. I ended up getting a more costly one at a local store that specified data transfer and it worked right away.

3 Likes

Great to hear, thanks @retroshaun!