Arduboy stuck on white screen

Hello everyone

I received my kickstarter arduboy yesterday and have been playing around with it since then with no problems. But now the arduboy is only showing a white screen after the scrolling arduboy logo has appeared. Uploading a new program will still reboot the device and show the logo but then immediately it goes to the white screen again.

I’ve tried the reset procedure multiple times with no luck and a different usb port also hasn’t made a difference. Seeing as it still accepts new uploads it doesn’t feel like it’s bricked but I’m not having much luck trying anything else. The flashlight mode (holding up button?) turns the screen completely black but I does not seem to set the LEDs to 255 like the comment suggests. Hopefully someone has encountered this problem before and knows a workaround!

EDIT: Ended up just needing a reset afterall! The timing of it seems quite tough haha! I ended up pressing the upload button and then quickly resetting the device which worked first try.

1 Like

See this

1 Like