Arduboy successfully uploading, but no working screen

Hello-

I often times carry my arduboy with me to play games but yesterday I got tired of the game that I had on there for a couple of months so I tried uploading a new game but then I ran into the issue of the screen not working. I know that the program was running because the rgb lit up, but the screen is not working. I then went to the Arduboy page and saw the tutorial for flashlight mode and reset, of which I’ve tried multiple times to no success. I’ve been using team arg’s siren game because that is what originally came on the arduboy. but nothing is working. The weird part is that when I turn it on, the rgb flashes but so does the green boot led (most times 3 flashes). Does anyone have an idea of what to do?

Also I haven’t meddled with the screen in any noticeable way that would cause it to not work.

Thanks

  • Which game did you upload?
  • How did you upload it?
    • E.g. Compile from source, used a specific uploader tool…
  • What happens when you start the Arduboy?
    • I.e. the specific sequence of events

Any chance the Arduboy was in your backpack or being moved around a lot?

It kinda sounds like the connection to the screen was broken.

If you can write into www.arduboy.com/contact with information on where you purchased it we can help get it fixed for you.

Sorry about the problem, thanks for writing in!

Yeah I love to have my arduboy in my bag and in my pocket, often times with other things. It makes sense because when I found out it wasn’t working, it had just been in my bag.

Thanks