Arduboy Unresponsive HELP!

I just received my Arduboy today in the mail, after playing the preinstalled game “Siréne” for some time I wanted to try to upload something new. I am using a Mac, so I downloaded the Arduino software and watched a few tutorial videos about the proper way to upload a new game. I found this link https://github.com/atomic-salamander/puzzle_pack and decided to give it a go (For the record, I am not coding savvy whatsoever) I hooked up the board (Arduboy) and port (leonardo) and clicked sketchbook/upload. My Arduboy went black and stopped responding. I looked up resetting information, The flashlight mode does not work, the reset button doesn’t work. I have tried to upload the brick breaker game with no success either. I received an error while uploading that said
“Arduino: 1.8.5 (Mac OS X), Board: “Arduboy”/Users/Nick/Documents/Arduino/arduman_arduboylib11/arduman_arduboylib11.ino:1:21: fatal error: Arduboy.h: No such file or directory #include <Arduboy.h> ^compilation terminated.exit status 1Error compiling for board Arduboy.This report would have more information with"Show verbose output during compilation"option enabled in File -> Preferences.”
Whenever I plug my arduboy in, The red light indicating battery lights up, and every 5 seconds or so a green led flashes.
Any help will be greatly appreciated!
(Again, I haven’t the slightest clue on how coding works, so please be patient)

That’s not an upload error, that’s a compilation error.
Source code must be turned into machine code before it can be uploaded, via a process called compilation.

That error means the code didn’t compile because that game uses the old Arduboy library (which has been replaced by Arduboy2), and because you didn’t have the old library installed, it couldn’t compile.


From the looks of it, the puzzle pack was written for the Arduboy devkit (the precursor to the Arduboy).

So it would seem that might be the cause of your Arduboy being unresponsive.


The first thing to do would be to make sure you’ve got the right libraries installed.
That’s covered by step 2 and 3 on this guide.

Then try compiling something a bit more modern.
Perhaps LoveRush (a “shoot 'em up”).

You are an absolute lifesaver! Thank you so much, I have it running right now. For a second I thought I was going to have to buy another one :slight_smile:

1 Like

Glad you were able to get this working!! :smiley:

2 Likes

I did a bit of digging.
If you still want to play puzzle pack, someone updated the library to get it running on actual Arduboy units:

Thankfully there aren’t many games that have that issue.
I think you were just a bit unfortunate with your selection, most games that worked on devkit got updated after the actual Arduboy was released.