Arduboy Uploader


This is my Arduboy Uploader for Windows:


Browse games here:

How to use it:


Very cool! I love it!

Just 1 suggestion… Due to licensing, many games you have uploaded require the author to be cited, so it would be cool to see their info listed.


Added a button with the author/license info :smiley:

Would be even better if it would work with .arduboy files … (or maybe it does)

EDIT: It does support .arduboy files now


Mmmmm I just can’t seem to get the uploader to work. I’ve downloaded the uploader, installed it, now at and clicked on “upload to arduboy”, a dialog pops up “open url :arduboy protocol?”, click ok and the uploader pops up scans a bit and turns red and fails.Retry, and same thing. Every game I tried won’t upload.

Have restarted arduboy, reconnected arduboy, restarted computer, held up when booting arduboy, tried everything except reinstall Leonardo drivers because Arduboy Manager and IDE is working A-ok anyways.

Not sure what’s up. Tried the uploader offline, picked my own .hex file and won’t upload either.

Strange :confused: it is not finding your Arduboy, does the Arduboy Game Loader works too? Arduboy Game Loader by TEAM a.r.g

I think it did find my arduboy, it puts it into bootloader and then loses it somewhat after the com port switches I think. Never tried teamARGs loader, will give it a go later and check.

just downloaded and tried the TEAMarg loader and it works.

fwiw on my comp, arduboy is on COM7 and bootloader is COM8, TEAMarg’s loader has helpful messages saying it first detects arduboy on COM7 and then when it switches to COM8 it says so too, then and I can hear the comp beep and then when it resets there’s another beep.

But, with your uploader, I can hear the first beep when it switches but then probably fails to find COM8, after a few secs arduboy resets without loading.

Oh, maybe I need to increase the delay of waiting. Right now it aborts the procedure if the Arduboy does not come up back in 6 seconds

Can you try the version 0.4 ? (I increased the delays a bit)

just downloaded, reregistered associations, went to your page clicked on a game upload, little screen pops up turns red and fails at the same time comp beeps. :frowning:

meanwhile, arduboy’s screen is blanked and then resets in a bit.

If you go to the Windows event viewer do you see a warning like the one in this pic?:

nope but this is what I got:

Fault bucket , type 0
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: abupload.exe
P3: 59102e71
P4: mscorlib
P5: 4.0.30319.18444
P6: 52717edc
P7: 1368
P8: 13
P9: System.ObjectDisposedException

That probably came later after the failed upload, if I leave the pop up windown on, abloader running it faults after a while.

Ahh… you need to download and install the .Net framework 4.5

I am going to put that into the requirements if that fixes your problem. I have only 3 machines and all of them are with Win 10

1 Like

mmm strange, I do have .NET framework 4.5.1 installed.

Are you in Windows 10?

nope, running Win 7.

I am going to test it later in a Win7 VM to make sure it runs properly. If you want to try to install 4.5.2, go ahead and tell me if that fixes your problem.

I can recompile it to a lower framework

downloading 4.5.2 now, will try later and let you know if it works. Thanks much.

I have now installed 4.5.2 but I’m still getting the same problem, log shows the same problem, strangely it’s still using .NET framework 4.0 (this version doesn’t show up in the uninstall list probably built into the system)

Application: abupload.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.ObjectDisposedException
   at System.Runtime.InteropServices.SafeHandle.DangerousAddRef(Boolean ByRef)
   at System.StubHelpers.StubHelpers.SafeHandleAddRef(System.Runtime.InteropServices.SafeHandle, Boolean ByRef)
   at Microsoft.Win32.UnsafeNativeMethods.GetOverlappedResult(Microsoft.Win32.SafeHandles.SafeFileHandle, System.Threading.NativeOverlapped*, Int32 ByRef, Boolean)
   at System.IO.Ports.SerialStream+EventLoopRunner.WaitForCommEvent()
   at System.Threading.ThreadHelper.ThreadStart_Context(System.Object)
   at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
   at System.Threading.ThreadHelper.ThreadStart()

Any reason why abupload uses framework version 4.0?

These are installed on my system, current and older below:

C:\Users\sen>wmic product get description | findstr /C:.NET
Microsoft .NET Framework 4.5.2
Microsoft .NET Framework 4.5.1 (CHT)

C:\Users\sen>dir  /b  %windir%\Microsoft.NET\Framework\v*