Arduboy Wont keep a charge

I bough 2 Arduboys 1 of them when i pulled it out of box was in the on position and battery was dead i charged it overnight but still wont stay on unless i plug it in and thing i can do here is my order


Personal information redacted by moderator.

please help as one was for a birthday present

If you haven’t already please use www.arduboy.com/contact to help resolve your issue. We can repair or replace your Arduboy but due to the current global situation everything is taking more time. Your patience is appreciated and we apologize for the problem.

3 Likes

yeah no hurry as ii understand the current situation we are all in and im almost 95% sure itts not keeping a charge but also it wont stay on when pluged in

also i can get the hello world example from arduno ide to work when its not pluged in but everthing else wont

Just to check…

Have you got the Arduino IDE set to use ‘Arduino Leonardo’ as the board type?

It should say “Arduino Leonardo” in the bottom right corner.
You can also check with Tools > Board: "Arduino Leonardo.

Also, which games have you tried?

i have tred micro city but it comes on for a second and then turns off

And you definitely have ‘Arduino Leonardo’ set as the board type?

If so, this sounds like it’s some fault with either the battery or the battery circuit,
in which case a replacement would be the best option,
so @bateske’s advice about using the contact form to request a replacement would be ideal.

Just as a precaution though, have you tried charging with a different USB cable?

I recently had a case where what I thought was a problem with a battery turned out to be a weakness in the charging cable I was using and switching to a different cable solved the issue.
(It was my 3DS rather than my Arduboy, but the same principle applies.)

1 Like

yes i tryed it

i just said im having problems in the contact forum shold i say i need a replacment

well what happenes is i trun it on i see a light flash on then off it like the screen is not working

i qould at leaset like a responce and if i didnt give you correct info please let me now do not just waite till u can repair or replace it i dont care if it take a while

also if there is still someone stuff i can do to try to fix it on my own i’ll try

If you want to open it up and have a careful look I think you will find that one of the solder tabs has fractured at the point where it is soldered to the PCB. Unfortunately there is no way to repair this without a spot welder of some kind as the remaining tab cannot be fused with solder.

The only option is to replace it with another battery which can be bought here:


https://www.powerstream.com/thin-lithium-ion.htm

It’s $10 in quantity 1 though, you might be able to find cheaper options elsewhere.

I can repair it, because I have some of these batteries laying around, but unfortunately the turnaround time is going to be more than a month on that due to everything that is going on.

I’ve emailed you directly to try and resolve this as it sounds like you may be having some issues with using the contact form and hopefully we can solve it there.

1 Like