Arduboy won't show up in 'Device Manager'

Hi im super new to arduino and kind of technically challenged. I’ve been trying to upload games to my Arduboy but nothing seems to work. I’ve re-downloaded the arduino drivers, restarted my computer, and changed usb’s multiple times. I’m on windows 7 and for whatever reason it wont show up at all in device manager. the green light flashes when I plug in the Arduboy boy, a popup shows on my computer saying the driver could not be updated. I was able to upload one game to it earlier but for whatever reason it doesnt work now. Any help would be greatly apreciated.


When you keep device manager open and connect your Arduboy (with power on). Do you see it popup shortly as Arduino Leonardo?

while Arduboy is connected to your PC, press and hold the up button and then turn on Arduboy.

You can also try pressing the reset button at the left of the micro USB port. does it show up in device manager?

What was the game you’d successfully uploaded?

When I connect with the power on nothing shows up, same when I hold the up button and then turn it on while connected. When I pressed the reset button while plugged in it shows up as unknown device for a few seconds, then disappears after a ‘Driver Cannot be installed’ popup appears. The game I was able to upload was Karateka.

Update:I just reset it again and now it shows up in device manager as 'ARDUINO LEONARDO BOOTLOADER (COM5). I still cant upload though it seems.

ok good try this with Arduino IDE opened and a sketch loaded:

  • go to tools menu and make sure Arduino Leonardo is selected as board
  • press CTRL + R or click the checkmark button to recompile sketch (will speed things up for upload)
  • press the reset button on Arduboy
  • quickly go to tools > port and select port COM5
  • press CTRL + U or upload button to upload sketch
  • quickly press the reset button on Arduboy again

After pressing reset, Arduboy weill remain in bootloader mode only for 8 seconds. If the upload takes long you need to time pressing reset

After resetting my Arduboy, it disappeared from device manager again. I was able to reset once more and able to change the port to com 5 but then the recompile sketch failed. Here’s the error: Arduino: 1.8.5 (Windows 7), Board: “Arduino Leonardo”

C:\Users\Administrator\Desktop\ARDUBOY\Midnight_Zoo_1_0\Zoo_1_0\Zoo_1_0.ino:12:22: fatal error: Zoo_data.h: No such file or directory

#include “Zoo_data.h”


compilation terminated.

exit status 1
Error compiling for board Arduino Leonardo.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

The Arduboy then disconnected again from device manager.
Update: The arduboy will now only stay connected during the 8 second reset window, it also shows up as com4 now.

Please follow the Adding Programs guide to properly install Arduboy programs.

Thank you for the guide! i believe I have properly installed a sketch into the sketchbook now. My issue currently is that I am unable to change the port in the IDE. After a reset the arduboy will show up in ‘Device Manager’ for as long as the reset lasts, but after 8 seconds it will disappear again. Every once in awhile it will stay in device manager after the reset, but I will be unable to select the port in the IDE. Often when I reset the Arduboy it will appear as (com4) which usually disappears from the device manager. It will show up as (com5) if it stays connected after the reset.

Sort of found a weird fix. I was able to successfully upload a new game by holding down the reset button while the sketch was compiling and immediately letting go of the button as soon as it started to actually upload. For whatever reason it worked!

You did it. Nice.
Make sure the sketch compile before upload. If something is wrong with the program it will not even try to upload it unless you solve the problem somehow.
The Arduboy should appear as a COMM port (whatever you have seen on your computer was right), but it just keep cutting in and out. I don’t know. Make sure that it is attatched NOT to a external USB hub as they are…well, not as responsive as a USB on the motherboard would and sometimes they will not support the USB. Also consider having a better cable for a stable connection. The cable that come with the Arduboy would be a good choice, but consider swapping it out with a still better quality one as the original one bite too deep into the port. It is a good cable though.
Make sure you select the board type “Arduino Leonardo” before you upload inside Arduino IDE. One reason you cannot change the port is that the selected board is not correct and the other was the board (Arduboy) itself. The computer checks to see if there is such board. If there is none, it will not give you a option of choosing the board. Once there, uploading anything made in the Arduboy libary (distinguishable from #include <Arduboy.h> or #include "Arduboy2.h") will have the device up and go.
My stock program (the program that comes with the Arduboy) also have difficult time working with the computer. Seems like TEAM A.R.G. wasn’t too good with their bootloader.

Do you have to do that every time?

If you don’t and it’s behaving normally we can call this one ‘solved’.

If you do have to do that every time, that’s not normal behaviour.

My guess is that the bootloader isn’t working properly, or that possibly there’s a hardware issue.

If you’re happy using the workaround then just keep using it,but if you want the probem fixed then I’d suggest either:

  • keep asking for advice here to see if anyone can think of something (we’ve got a lot of clever and helpful people here)
  • ask the place you bought it from (since it’ll probably be under guarantee assuming it’s fairly new)
  • to use the contact form to ask Arduboy Inc to take a look at it.

The last two options would mean being without your Arduboy for a while (how long depends on how busy the respective companies are), so I could understand that you might want to put those off if you can help it.

1 Like