Arduboy2 SE doesn't allow port selection [Solved]

Hi,

Got my Arduboy 2 SE the other day and have been trying to get it to respond to the Arduino IDE for two days. I’ve tried an Ubnutu 17.10 laptop, a windows 8.1 and three different cables but whilst the red light comes on to power it, I can never get the IDE to enable the Ports menu option. Arduino Leonardo has been selected but the Ports option remains greyed out. The IDE says that it is using port 1 but if I try anything it says that it cannot connect to an Arduino. Any ideas please?

Ok… i know it sound simple but… you do know that you have to turn ON the arduboy for it to be detected right?

1 Like

What’s an Arduboy2 SE?

There’s only the Arduboy and the Arduboy devkit (which is no longer produced).

The red light means it’s charging, it doesn’t mean that the Arduboy is on or powered.
@Vampirics’ suggestion of the Arduboy being turned off seems likely.
The switch is at the top.

1 Like

Sorry to disappoint, but yes, it’s on. I can tell from the infernal ever accelerating music. :wink: I even irritate myself by turning it off an on again just to be sure.

And sorry, yes Arduboy SE. Not sure where I got the 2 from.

You’ve tried different computers, have you tried a different cables?

Also, what do you mean by ‘SE’?

The library is called Arduboy2 so that’s probably what you were thinking of with the 2.

(You can turn the infernal music off by the way, just hold B and Down when you start it up.)

I read that Arduventure has no USB support in normal mode so you won’t see it as a serial port nor can you select the port in the Arduino IDE. However when you press the reset button on your Arduboy (SE), it will enter bootloader mode for 8 seconds and it will be detectable as a serial port during those 8 seconds. During this time you can reflash it.

Note if you flash your Arduboy SE now with different content you won’t be able to flash Arduventure back again for a while as it is not yet available for download.

1 Like

Special Edition ?   

1 Like

I had considered “Standard Edition” but not “Special Edition”.
I just call it “The Arduventure Arduboy” under the assumption that there will one day be other special editions.

In that case @Mr.Blinky is probably right here.

Yes, it’s the Indiegogo one that just delivered. Special Edition. I think that means it’s black. :wink:

In that case @Mr.Blinky’s advice is definitely correct.
While you’ve got Arduventure loaded your Arduboy won’t be detected through normal means,
you’ll have to use the reset button on the bottom.
I recommend a mechanical pencil without the lead or a sim card remover.

Something like a toothpick or sewing needle will work, but those can cause damage if you’re not careful, so it’s best to blunt the toothpick and use the blunter end of the sewing needle if you choose to use one of those.

Remember that if you remove Arduventure you’ll have to wait a week or two before you can play it again because the download information hasn’t been released.

Hi,

Thanks. I shall try that in the morning. Not fussed about that game. I bought it to code my own games and there are plenty more to download if I need a game to try. Thanks.

Not true. Go to http://arduboy.com/arduventure/ and follow the directions under the Reprogramming Guide heading.

I was merely taking @Mr.Blinky’s word on the matter:

Yes and no. I can get into that upload state on the Arduboy as per your instructions, but I still can’t see it as a port. The screen goes blank but port is still unselectable from the IDE. Upload can’t find the board still.

Does the Arduboy SE have a non standard (modified) bootloader that keeps the bootloader mode active longer then the standard 8 seconds?

I didn’t know you could select the bootloader through a menu option in Arduventure. good to know that.

I’ve timed mine and I would say that it’s still 8 seconds. What is it exactly that I can do during that time? I’ve tried selecting the port but that doesn’t work. I’ve tried (somewhat optimistically) various other upload, bootload etc options but I fail to see how they would work if I don’t have the right port selected.

So I’m still stuck.

Did you try team arg‘s uploader and the uploading procedure for arduventure on their website?

No. What happens is the bootloader runs for 8 seconds, then starts the sketch. The sketch’s main() detects the UP button still being held and immediately starts the bootloader again.

You can try selecting
Tools > Port
near the end of the 8 second window. Hopefully the port will have been detected by then and you’ll be able to select it.

I’ve tried this https://arduboy.com/download-and-learn-arduino/
but I don’t get the port option.

I’m running Ubuntu so I can’t run the Windows utilities. I’m not fussed about playing the other games available, I’m trying to re-learn to code and so have got this for the Arduino IDE interface.