Arduboy2 SE doesn't allow port selection [Solved]

I read that Arduventure has no USB support in normal mode so you won’t see it as a serial port nor can you select the port in the Arduino IDE. However when you press the reset button on your Arduboy (SE), it will enter bootloader mode for 8 seconds and it will be detectable as a serial port during those 8 seconds. During this time you can reflash it.

Note if you flash your Arduboy SE now with different content you won’t be able to flash Arduventure back again for a while as it is not yet available for download.

1 Like

Special Edition ?   

1 Like

I had considered “Standard Edition” but not “Special Edition”.
I just call it “The Arduventure Arduboy” under the assumption that there will one day be other special editions.

In that case @Mr.Blinky is probably right here.

Yes, it’s the Indiegogo one that just delivered. Special Edition. I think that means it’s black. :wink:

In that case @Mr.Blinky’s advice is definitely correct.
While you’ve got Arduventure loaded your Arduboy won’t be detected through normal means,
you’ll have to use the reset button on the bottom.
I recommend a mechanical pencil without the lead or a sim card remover.

Something like a toothpick or sewing needle will work, but those can cause damage if you’re not careful, so it’s best to blunt the toothpick and use the blunter end of the sewing needle if you choose to use one of those.

Remember that if you remove Arduventure you’ll have to wait a week or two before you can play it again because the download information hasn’t been released.

Hi,

Thanks. I shall try that in the morning. Not fussed about that game. I bought it to code my own games and there are plenty more to download if I need a game to try. Thanks.

Not true. Go to http://arduboy.com/arduventure/ and follow the directions under the Reprogramming Guide heading.

I was merely taking @Mr.Blinky’s word on the matter:

Yes and no. I can get into that upload state on the Arduboy as per your instructions, but I still can’t see it as a port. The screen goes blank but port is still unselectable from the IDE. Upload can’t find the board still.

Does the Arduboy SE have a non standard (modified) bootloader that keeps the bootloader mode active longer then the standard 8 seconds?

I didn’t know you could select the bootloader through a menu option in Arduventure. good to know that.

I’ve timed mine and I would say that it’s still 8 seconds. What is it exactly that I can do during that time? I’ve tried selecting the port but that doesn’t work. I’ve tried (somewhat optimistically) various other upload, bootload etc options but I fail to see how they would work if I don’t have the right port selected.

So I’m still stuck.

Did you try team arg‘s uploader and the uploading procedure for arduventure on their website?

No. What happens is the bootloader runs for 8 seconds, then starts the sketch. The sketch’s main() detects the UP button still being held and immediately starts the bootloader again.

You can try selecting
Tools > Port
near the end of the 8 second window. Hopefully the port will have been detected by then and you’ll be able to select it.

I’ve tried this https://arduboy.com/download-and-learn-arduino/
but I don’t get the port option.

I’m running Ubuntu so I can’t run the Windows utilities. I’m not fussed about playing the other games available, I’m trying to re-learn to code and so have got this for the Arduino IDE interface.

Well then my answer is still true, But you could say it’s incomplete. Some PC’s may have a issue though with the fast USB detach and (re)attach

With that feature you could also just press the UP button continiously and switch Arduboy (SE) on to enter bootloader then.

@CaptainFuzzyFace you could try this

  • In Arduino IDE go to preferences (you can press CTRL + comma) and at the option ‘show verbose output during:’ put a checkmark at the box ‘compilation’ and a checkmark at the box ‘upload’ and click OK

  • Press the reset button (or choose the bootloader option from the menu) and wait a second
  • Now quickly go to the ‘Tools’ > ‘Port’ menu and select the com port (In case of multiple com ports choose the one with highest number)
  • Press the upload button and watch the black status window in the IDE
  • when you see the text PORTS {} / {} => {} appear repeatedly press the reset button on Arduboy again (or the menu option).

This usually works on windows I’m not sure if the verbose port output is available on linux.

1 Like

That’s what i use (Ubuntu 16.04) and it works for me.

In Ubuntu Linux the port will likely show up as:
/dev/ttyACM0 (Arduino Leonardo)
which is what you want to select (not the highest number).

1 Like

For Ubuntu Linux, you can open a terminal window and enter the command:
dmesg

If the Arduboy is being detected, the output should contain lines near the end of the output similar to:

[ 2315.260055] usb 7-2: new full-speed USB device number 2 using uhci_hcd
[ 2315.445087] usb 7-2: New USB device found, idVendor=2341, idProduct=0036
[ 2315.445093] usb 7-2: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[ 2315.445097] usb 7-2: Product: Arduino Leonardo
[ 2315.445100] usb 7-2: Manufacturer: Arduino LLC
[ 2316.016325] cdc_acm 7-2:1.0: ttyACM0: USB ACM device
[ 2316.018899] usbcore: registered new interface driver cdc_acm
[ 2316.018903] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[ 2322.920135] usb 7-2: USB disconnect, device number 2

Yes, it is, as are all the other options in the Preferences window.

1 Like

Problem solved. Not sure which bit fixed it, but I ran the full arduino-core install, disabled the modem from monopolising the serial port and then followed the video. All sorted. Thanks. :slight_smile:

1 Like