Arduboy2 SE doesn't allow port selection [Solved]

Well then my answer is still true, But you could say it’s incomplete. Some PC’s may have a issue though with the fast USB detach and (re)attach

With that feature you could also just press the UP button continiously and switch Arduboy (SE) on to enter bootloader then.

@CaptainFuzzyFace you could try this

  • In Arduino IDE go to preferences (you can press CTRL + comma) and at the option ‘show verbose output during:’ put a checkmark at the box ‘compilation’ and a checkmark at the box ‘upload’ and click OK

  • Press the reset button (or choose the bootloader option from the menu) and wait a second
  • Now quickly go to the ‘Tools’ > ‘Port’ menu and select the com port (In case of multiple com ports choose the one with highest number)
  • Press the upload button and watch the black status window in the IDE
  • when you see the text PORTS {} / {} => {} appear repeatedly press the reset button on Arduboy again (or the menu option).

This usually works on windows I’m not sure if the verbose port output is available on linux.

1 Like

That’s what i use (Ubuntu 16.04) and it works for me.

In Ubuntu Linux the port will likely show up as:
/dev/ttyACM0 (Arduino Leonardo)
which is what you want to select (not the highest number).

1 Like

For Ubuntu Linux, you can open a terminal window and enter the command:
dmesg

If the Arduboy is being detected, the output should contain lines near the end of the output similar to:

[ 2315.260055] usb 7-2: new full-speed USB device number 2 using uhci_hcd
[ 2315.445087] usb 7-2: New USB device found, idVendor=2341, idProduct=0036
[ 2315.445093] usb 7-2: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[ 2315.445097] usb 7-2: Product: Arduino Leonardo
[ 2315.445100] usb 7-2: Manufacturer: Arduino LLC
[ 2316.016325] cdc_acm 7-2:1.0: ttyACM0: USB ACM device
[ 2316.018899] usbcore: registered new interface driver cdc_acm
[ 2316.018903] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[ 2322.920135] usb 7-2: USB disconnect, device number 2

Yes, it is, as are all the other options in the Preferences window.

1 Like

Problem solved. Not sure which bit fixed it, but I ran the full arduino-core install, disabled the modem from monopolising the serial port and then followed the video. All sorted. Thanks. :slight_smile:

1 Like