Arduino MacOS10.13.4でシリアルポートが開かない


#1

Arduino UNOを使い始めたのですが、10.11.6では問題なく通信できます。
選択されるポートは/dev/cu.usbmodem1411
しかし10.13.4では/dev/cu.usbmodem1431と言うポートが選択されるのですが、エラーがでて通信出来ません。当然ボード上のTX,RXは全く点灯せず、以下の様なエラーメッセージが出ます。
10.13.4についての情報が無くこちらで質問させていただく次第です。
よろしくお願いいたします。

------------------------------以下エラーメッセージ----------------------
Arduino:1.8.5 (Mac OS X), ボード:“Arduino/Genuino Uno”

最大32256バイトのフラッシュメモリのうち、スケッチが928バイト(2%)を使っています。
最大2048バイトのRAMのうち、グローバル変数が9バイト(0%)を使っていて、ローカル変数で2039バイト使うことができます。
/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf -v -patmega328p -carduino -P/dev/cu.usbmodem1431 -b115200 -D -Uflash:w:/var/folders/_r/688ntz4d4fl9cx1_c0dy4ql40000gn/T/arduino_build_462810/Blink.ino.hex:i

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:01:35
Copyright © 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright © 2007-2014 Joerg Wunsch

     System wide configuration file is "/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf"
     User configuration file is "/Users/yoshifumiinomata/.avrduderc"
     User configuration file does not exist or is not a regular file, skipping

     Using Port                    : /dev/cu.usbmodem1431
     Using Programmer              : arduino
     Overriding Baud Rate          : 115200

avrdude: ser_open(): can’t open device “/dev/cu.usbmodem1431”: Resource busy

avrdude done. Thank you.


(Kevin) #2

It looks like you have the “Genuino Uno” board selected.

You should be using the “Leonardo” board type.

Try that and see if it works. Good luck!


#3

Thanks Kevin,
I tried it,but the result was the same.
When I used 10.11.6, I connected with the “Genuino Uno” board selected without problems.


(Kevin) #4

hmm… It seems the problem is somewhat related to having arduino set up. Maybe you could ask for support in their forum also?


(Pharap) #5

What game do you have on your Arduboy?

If you previously compiled something for Genuino Uno and uploaded that to Arduboy then that could be a problem.


#6

Thanks for the advice.
No, I will use UNO for the first time.
My problem is that macOS High Sierra can not communicate with the board in serial.


(Pharap) #7

This might help:

There are some other comments in the thread that might help.