Arduventure 1.0.1 reprogramming guide doesn't work

Hi, I just bought my Arduboy, i tried some games out on it, then eventually installed Arduventure 1.0.1 through Arduboy Manager 1.2.5 by importing it’s Arduventure.arduboy file. I installed it on the Arduboy, it works fine. Then I wanted to reprogram it to another game, when I choose the upload option within the game, i hold the “DOWN” button (as it’s now DOWN not UP), and once I’m holding it the computer cannot recognize the Arduboy, the USB detection sound happens then within seconds it has the disconnection sound, then continually the disconnection USB sound every 4 seconds.

I have tried to click “Transfer” to upload a game so many times in the window of hearing the initial USB detection sound, it always says “Transfer Error”. I’ve tried multiple micro-usb cables and also Multiple computers. I’ve tried a USB hub as well as not. Each computer does the same thing.

Basically Arduventure 1.0.1 is now permanently on my Arduboy with no way of ever having another game on it.

If anyone can please help that would be great,
Thank you,
Jason

Alternatively you can also hold DOWN while turning ON the Arduboy and then press the button to upload.
In all honestly i never had issue uploading over Arduventure, but i am using Arduino IDE, not an Arduboy manager.

Which one?
There are several different managers.

Ok I just tried holding DOWN while turning it on, it does the same thing. In Windows 10 or Windows 7, two different computers both have an initial USB detected sound, then every 5 seconds after that is the USB disconnected sound.

I’m using this one: http://www.crait.net/arduboy/

If you have Python 2.7 installed with pySerial or don’t mind installing. You can use my erase-sketch Python script to erase the sketch.The bootloader then doesn’t dissapear after x seconds.

1 Like

I don’t even know if it has a bootloader. The computer can’t detect the device, how can I do anything?

Has anyone tried to install the new Arduadventure 1.0.1 update that came out 12 days ago?

Did you try to install and use Arduino IDE?

I can confirm it work perfectly with version 1.0.1

You just need to :

  • Have the sketch loaded in the Arduino IDE
  • Once it’s all loaded, turn the arduboy ON with the DOWN arrow pressed
  • Press the upload button in the Arduino IDE without releasing the down arrow, keep it pressed until the upload is completed.

It never failed me and i don’t even have to time it right, it just works everytime.

1 Like

I give up,

thanks though.

give it another try in a few days. I had a hard time getting Lode Runner off my arduboy. Followed the troubleshooting guides and figured it out.

2 Likes

I can confirm that it won’t work either with craits or team arg’s uploaders. You have to use arduino and then find the right timing.

2 Likes

Don’t give up!

As mentioned by @Nicole_Birgel you’ll have to use Arduino to do the reprogramming, the game uploaders can’t change away from Arduventure.

If you are still struggling please write to us at Contact — Arduboy and we can work with you directly to solve the issue one way or another. Don’t lose hope!

4 Likes

Arduboy has normally two USB interfaces:

  • The USB bootloader which is responsible for uploading a new sketch/program to your Arduboy.

  • USB serial which is normally available when a sketch/program is running on Arduboy.
    This USB serial can be used to exchange data between Arduboy and a PC but it is also used
    to select bootloader (programming) mode by the Arduino IDE and uploaders.

The USB serial part was removed on Arduventure to make it fit in the available memory.
So it is not possible for uploaders to detect Arduboy and select the bootloader automatically.
The bootloader has to be selected manually. With Arduventure 1.0.1 this can be done in 3 ways:

  • Press the reset button
  • press and keep depressing down and then power on Arduboy
  • Select upload from the menu and press and keep depressed DOWN button (UP button on older versions)

When the bootloader mode is selected Arduboy will only remain in this mode for 8 seconds and then start the game again. By holding down the down button in Arduventure. The bootloader mode is selected again as soon as it ends. This is the constant connect and disconnect you’re experiencing. It looks like this constant connect and disconnect is problematic for the uploaders. By using the Arduino IDE it’s easier to time when to do the upload. Using my python scripts timing is even easier.

Install Python 2.7 and pySerial

  • Download python 2.7.15
  • Run the installer and on the options menu make sure ‘Add python.exe to path’ is also checked (basically you’re selecting all options)
  • reboot your PC
  • Go to start > run or press Windows key + R simultaniously
  • copy and paste the following line in the run edit box:
pip install pyserial
  • press enter or click OK

Download python scripts

  • Click this link
  • click green Clone or Download button in the top right
  • click Download ZIP
  • Unpack the zip file and open the folder.

Remove Arduventure 1.0.1 (and up)

  • turn Arduboy off
  • press the down button and keep it depressed
  • turn Arduboy on
  • wait for the connect sound or wait 3 seconds
  • double click erase-sketch.py

By erasing the sketch (program) the bootloader mode will not end after 8 seconds and will remain active which shouldn’t be a problem for the uploaders.

If you’ve downloaded games as .hex or .arduboy files you can also drag and drop them on to the uploader.py to upload them to Arduboy.

When you double click uploader-create-send-to-shortcut.vbs, a shortcut to the uploader script is added to Windows Explorer’s Send to menu. You can upload .hex and .arduboy files from Windows Explorer by right clicking them, choosing sendto and then Arduboy Uploader

As a bonus there are also scripts to backup and restore EEPROM (Save Games)

7 Likes