Arduventure - 12th TEAM a.r.g. game

You have the board ‘Arduino/Genuino Uno’ selected. You need to select Leonardo or Arduboy.


Thanks <3

Now I feel like an idiot.

1 Like

Its not because you have made an error that made you an idiot… I hope, as else i’m too as i make alot errors and for me it more like that that i progress.

You mean “making mistakes does not make you an idiot”.
(Or “making mistakes doesn’t mean you are an idiot”.)

Indeed, making mistakes is completely expected.

The best way to get good at diagnosing error messages is to make the mistakes that cause the error messages.

I always checked the port but i completely forgot to check the board.

I tried to upload this game and I keep on getting an error that says “Error compiling for board Arduino Leonardo”. It also says that the sketch is too big, and memory is at 100%, so maybe that’s causing it.


Are you using v1.8.6 or v1.8.7 of the Arduino IDE?
If so, that could be releated.

I’m using v1.8.5 of the Arduino IDE.

Strange, I just tried compiling the master branch on v1.8.5 and I got:

Sketch uses 27922 bytes (97%) of program storage space. Maximum is 28672 bytes.
Global variables use 1624 bytes (63%) of dynamic memory, leaving 936 bytes for local variables. Maximum is 2560 bytes.

Are you sure you’ve got the board right?
Try redownloading the latest master branch.

Here’s what it looks like on my computer:


It still isn’t working, unfortunately

Make sure you use the latest Arduboy2 library. You can do this as following :

go to Sketch > include library > Manage library then in the text box in the top type Arduboy2 select version 5.2.0 and click update.

You may also want to repeat that for the ATMlib library

corrected version number

1 Like

Like @Mr.Blinky said, make sure your libraries are up to date.
Also, did you redownload the source from the master branch?

If your libraries and the code are up to date then the only other thing I can think of is to reinstall the IDE.

The latest Arduboy2 library version is actually 5.2.0

1 Like

Oops :blush: Thanks for correcting that

1 Like

I updated my libraries, redownloaded the source code, and reinstalled the IDE, but I’m still getting the same results. :confused:

Sketch uses 28928 bytes (100%) of program storage space. Maximum is 28672 bytes.

Global variables use 1625 bytes (63%) of dynamic memory, leaving 935 bytes for local variables. Maximum is 2560 bytes.
Sketch too big; see for tips on reducing it.
Error compiling for board Arduino Leonardo.

When I compile with Arduino-1.8.8 with board Leonardo selected :

  • Using library Arduboy2 at version 5.2.0
  • Using library ATMlib at version 1.2.6
  • Sketch uses 27894 bytes (97%)
  • Global variables use 1624 bytes (63%)

I don’t know which IDE you use and if you have any other libraries / packages installed but

  • if you have Try downloading the portable version of Arduino IDE (download zip, unpack into a folder of choice, create folder Portable inside that folder, run the Arduino.exe in that folder, install the libraries, open Arduventure and compile or upload)

  • If you have not Try uninstalling the IDE and delete the Arduino install folder (usually in C:]program files or C:\Program files x86) and delete folder Arduino15 in %localappdata% and then reinstall the IDE

1 Like

A post was split to a new topic: Problems with Arduventure Arduboy

the game seems to have corrupted and I can’t for some reason redownload the game

@Villager_guy135 You mean onto your computer? Try a different web browser? Or, it sounds like a computer problem maybe we can’t even help you? Or are you meaning upload, to the Arduboy?

2 posts were merged into an existing topic: New Maycar Arduboy clone has struggles