Arduventure question

Hey guys.
I recently bought an arduboy and I really love it!

I’ve been playing arduventure a lot but I’m currently stuck and I’m wondering if I’ve missed something or if it’s a unique bug.
I’ve just defeated the third boss and after checking my equip screen I still only have two amulets.
I’ve looked around the map of the area (I think it’s called the forest?) but so far I’ve found nothing.
I’ve been back to the boss room but there are no clues there either.
I can’t get into the next area (I’ve tried) and I feel like I’ve searched all over.

Please help!

1 Like

I think you may find the solution here:

I’ve still not got round to playing Arduventure despite owning the Kickstarter unit.

Hey mate. Thanks for your response!
That thread wasn’t much help, unfortunately.
You definitely should play it. It’s addictive as heck.

That does sound like a bug of some kind. Which version of Arduventure are you playing?

The most recent, I think. I will double check when I get home.
I can also post screenshots if it helps?

Is there a solution that doesn’t require me starting again? I clocked in several hours looking for the third amulet. :frowning:

Thanks for the reply, by the way!

Assuming the Amulet is saved in EEPROM then giving yourself the amulet should be as easy as toggling a flag in EEPROM.


Something to give a try, you can defeat the bosses as much as you want. Mabey beat the third boss again and see if it triggers your inventory?

Hi there!
I don’t know how to do that - sorry.

Hi there!
I hope its ok to post two times in a row?
I think you can only fight bosses agwin once you’ve ‘finished’ the game.
Ive tried and it just says something like ‘there’s nothing here/left to take when I hit’ a’ on the chest…

Are you playing the Kickstarter/Initial Release version, or did you upload the latest version from our website?

Edit: Try this latest version on github, it should let you re-battle the third boss. Please note down all the text after the battle is over so I can track down the bug if you don’t receive the amulet again.

Compiles with version 1.8.7 of the Arduino IDE.

Edit Again: Sorry, didn’t see you had said which version.

Hi mate!
The version I was playing was in fact the most recent. (ARDU_AB_v101.arduboy) I’ve re-flashed it just to be sure and the message I get (along with some other photos for explanation) can be found below.

Hey guys.
I’m starting to think my poor arduboy is defective. :frowning: I’ve had a few little issues like this one crop up, one after the other. Eep.

There really isn’t much hardware wise to go wrong with the arduboy so it is likely just bad luck with software bugs/glitches or something you are experiencing.

1 Like

What sort of issues?
Are you continually switching games without backing up your EEPROM first?

If so then I think your problem is that the games you’re playing are overwriting each other’s saves.

Hi mate!

For starters, I couldn’t get the sound to work on some games despite having the proper libraries installed in arduino. (I spoke to someone more experienced about this and he couldn’t figure out what was going wrong either)

Sometimes games don’t register my left directional button input straight away. This is fine for games like arduventure but I worry about how it’ll affect action-heavy games.

I’ve only really played arduventure and a few demos(?) that come with the arduino software.

That said, I should probably make a habit of backup once I resolve this issue and finish arduventure.
How do I do it?

You could use my Python utilities to backup EEPROM or a sketch or more.

1 Like