Arduventure (RPG)


#153

The latest version is still this one: http://siegfriedcroes.com/arduboy/arduventure/
Thanks btw :slight_smile:


(Muntin Doo) #154

Umm, Are you still working on this? You kinda stopped posting updates, so i’m assuming you’ve stopped :confused:.


#155

Don’t worry, I just took a break to work on some other projects. The game is still in development and @JO3RI is helping out! We’re reworking and optimizing my old (not so well written) code to save as much memory for content :wink:


(Cody) #156

Hi I’m new like this is meh first day but I’m ordering arduboy soon but I am amazed how small it is and how big this game is!


(Carlos) #157

I just tried this demo in a newly received Arduboy from seeedstudio and look great, very promising. However now I’m not able to load any other game. Anytime the Arduino IDE resets the arduboy to enter flash bootloader the game starts and IDE is not able to flash any other game :frowning:

Has anyone got this problem? any tips?


(Holmes) #158

Hey, @karman! Try using flashlight mode or using the reset button. :slight_smile:


(Cody) #159

Wow! Great game I love the graphics


(Curtis Ovard) #161

Late the the party on this thread but wow this game looks awesome. Great job on the huge world.


(Carlos) #162

Thanks. I’m already familiarized with arduino and knew the procedure. Tried by myself before posting here a couple of times without luck. Tried again after reading you and worked fine :stuck_out_tongue:


(Mathias Della Tonia) #163

Hello,
I just got my Arduboy a few days ago and I have not been able to install any game after Arduventure. I tried everything that was suggested, what should I do?


(Gavin Atkin) #164

There is a reset button near the usb port on the Arduboy. It’s a timing thing, I don’t remember the exact timing, but try pressing upload, waiting a moment then pressing the reset button on the Arduboy before the upload (on a different sketch) has finished. If that doesn’t work after a few tries, try pressing the reset button then upload. I think it’s the first way though if I’m remembering correctly.


(Mathias Della Tonia) #166

Thank you for the suggestion, I tried both ways, about 10 times each and still did not go through.
Thank you though!


(Scott) #167

Holding the UP button while powering up should enter flashlight mode. The RGB LED to the left of the display should light up white. Is this happening for you? If so, you should then be able to upload a new sketch.
http://community.arduboy.com/t/arduboy-gets-a-life-conways-game-of-life/578/10


(Mathias Della Tonia) #168

Thank you so much, that worked perfectly!


(Cody) #169

Please make a sequel I loved it


(Kevin) #170

Trying to figure out what is causing the units to lock up… We had this problem before where Arduventure took up too much ram and overwrites an address in RAM that is used to indicate a software reset.

But now we are using the latest bootloader on the Arduboy which moves the position in ram way out to the end, so this shouldn’t occur.

I’m pretty sure I remember testing this, is it possible these are being compiled with older versions of arduino?

@MLXXXp any suggestions? are you able to test this?


(Kevin) #171

Hello @karman and @MathiasTonia can you please tell us what version of Arduino you were running?

It looks like it’s an issue with Arduino 1.6.12 (possibly earlier, works just fine in 1.6.7, checking others…) and above broke something for us.

The flashlight mode will work to get it back, but you will need to close all instances of Arduino. Unplug and turn off the Arduboy and wait for the COM port to disappear. Then you can hold the up button while turning on the power, this will turn on the RGB led to full white indicating it’s ready to be programmed.

For beginners it’s not recommended to install this right now and if you do run into this issue check this thread and post your issues here:
http://community.arduboy.com/t/cant-upload-sketches-after-arduventure


(Gwenael) #172

Hi everyone,

I’m new here and I really want to try this game !
Still not a good idea to download it ?
I can’t wait xD.


(Gavin Atkin) #173

@Generu This demo I think will still work with the updated Arduboy library and Arduino IDE 1.6.7 it looks like. It can just make it difficult to flash your unit. You might need to put it into flashlight mode to flash a new game.


(Muntin Doo) #174

Can’t wait for this to be completed! :grinning: