Arduventure (RPG)

@Ground7
Hey now. We don’t allow the feeding of trolls here.

1 Like

Lol that’s the first I’ve been called a troll.
I answered the question. No trolling involved

If I came off a bit short I apologize, I can be pretty blunt at times.

1 Like

I think that @ethancawse is the troll that you are feeding?

1 Like

I thought it be best to think it was me first:P lol

Anyway now I’m really excited about this game being completed!:smiley:

2 Likes

If you want to make inverting ALL the graphics an option you could just do it in hardware and then it’s trivial.

When I try to compile and install using Codebender, it throws a few errors,

error: no member named ‘put’ in 'EEPROMClass’
error: no member named ‘get’ in ‘EEPROMClass’

codebender is in the dark ages, being only Arduino IDE v1.0.5 compatible. Those EEPROM functions are new to the Arduino IDE v1.6 series.

You’ll have to find some other way to implement the functionality if you want to get it to compile on codebender.

1 Like

I can’t seem to find the updated sketch (unless there isn’t one) either way I’m ignorant lol

This looks fantastic! Just want to see the finished game and play it on my Ardu! Nice work, keep going!

1 Like

I think it’s:
https://codebender.cc/sketch:221132#Arduventure.ino

The latest version is still this one: http://siegfriedcroes.com/arduboy/arduventure/
Thanks btw :slight_smile:

1 Like

Don’t worry, I just took a break to work on some other projects. The game is still in development and @JO3RI is helping out! We’re reworking and optimizing my old (not so well written) code to save as much memory for content :wink:

7 Likes

Hi I’m new like this is meh first day but I’m ordering arduboy soon but I am amazed how small it is and how big this game is!

1 Like

I just tried this demo in a newly received Arduboy from seeedstudio and look great, very promising. However now I’m not able to load any other game. Anytime the Arduino IDE resets the arduboy to enter flash bootloader the game starts and IDE is not able to flash any other game :frowning:

Has anyone got this problem? any tips?

Hey, @karman! Try using flashlight mode or using the reset button. :slight_smile:

Wow! Great game I love the graphics

Late the the party on this thread but wow this game looks awesome. Great job on the huge world.

Thanks. I’m already familiarized with arduino and knew the procedure. Tried by myself before posting here a couple of times without luck. Tried again after reading you and worked fine :stuck_out_tongue:

1 Like

Hello,
I just got my Arduboy a few days ago and I have not been able to install any game after Arduventure. I tried everything that was suggested, what should I do?