Ardynia - a Zelda style adventure

I’m not aware of any where the adventurers you sell stuff ‘die’,
but there’s one game I know of where you play as a shop keeper selling equipment and you have to hire a hero to go dungeon diving to acquire more stock.

“Recettear: An Item Shop’s Tale”

It’s notable for the catchphrases “Yayifications!” and “Capitalism, ho!” (which are only present in the English-language version).

Recettear got there first. :P

I love those shop type of games. Dragon’s Quest 4:Chapter 3, had you as a shopkeeper. One of the best and memorable chapter in that game. Maybe I can do cram one of those game on the Arduboy.

1 Like

If you still can’t find the sword, checkout, the Ardynia gif there shows the answer

1 Like

You know It would be great if someone made a Ardynia 2 with a bigger world, new dungeons, and so much more. hopefully that will happen soon.

1 Like

Anyone Know how to defeat the 3rd Dungeons boss?

A post was split to a new topic: I bought something I don’t understand please help me

friggin brilliant!

I’ve just discovered that the files for v1.1.0 (the supposed ‘final version’) don’t compile due to the following error:

sketch\src\entityTemplates.h:49:23: error: variable ‘entityProperties’ with dynamic initialization put into program memory area

const uint8_t PROGMEM entityProperties[NUM_ENTITIES * NUM_ENTITY_PROPS] = {


Unfortunately I can’t submit an issue or PR because the original repo has been archived, but I’ve created a fork that fixes the problem.

The .hex file should still work as normal, this only affects people who want to compile manually or can’t use the .hex file (e.g. because they’re using a clone that isn’t compatible with normal .hex files).

Thanks Pharap. I can unarchive the repo and merge this in.

edit: now unarchived.


Shall I make a PR then?

While you’re here, would it be too much trouble to ask for one more small change?

As it currently stands, if you want to compile from source you have to rename the enclosing directory to ‘ardynia’, which can be a bit of a trip hazard for people who aren’t familiar with the Arduino IDE’s foibles.

So would you be able to create a folder called ardynia and move ardynia.ino and the src directory into it to save people the extra step after downloading the source?

(I did this myself in my fork, but haven’t included it in the PR. I didn’t do it in a very clean way anyway.)

I created an issue for that: move .ino and src/ down into ardynia/ folder · Issue #5 · city41/ardynia · GitHub

I can’t just do it as I also need to update the Makefile and possibly some other bits. I don’t have any arduino dev tools setup right now, and I’d also want to make sure it still compiled and worked after making the changes. When I get some free time I’ll take a stab at this.

1 Like

The readme says for the IDE “it should build just as-is”. Did the IDE change? Can you not open the root ardynia folder that gets created after a clone?

After a git clone perhaps, but not after downloading it from GitHub.

When you download the source of a repo from GitHub and extract it, the branch name is always appended to the folder (e.g. ardynia-master) both when zipped and unzipped. This causes a conflict with the Arduino IDE’s rule about the .ino file name having to match the containing folder.

(The same issue occurs when downloading the source via a release.)

You’ve probably never had anyone complain about it due to a mixture of most people just using the .hex and people already aware of the issue doing a rename out of habit without stopping to think about it and how it affects other people who don’t know about the issue.

If you’ve been compiling with a makefile rather than the IDE or the Arduino toolchain that also might explain why you didn’t get the error I ran into when using the IDE. If the settings weren’t quite the same you might have had an extension that the IDE didn’t use.

I can’t help with the makefile, but I can confirm that what I did on my fork allows ardynia to compile out-of-the-box without the Arduino IDE throwing up that message.

Ah I see, that’s the key difference. I’ve never tested a direct download as I always clone repos.

I periodically tested compiling and running it from the IDE while I built the game. But again, not with a downloaded zip. That was also 3 years ago. So possibly the IDE has changed since then.

1 Like

Mmm bravo :clap:. Such an excellent game. Heck, I would even buy an Arduboy just for this game! I don’t have anything negative to say honestly. The only thing that I would ask for is more dungeons 'cause its so good! Great job @city41 !

Also I’m a little stuck. After you defeat the big bat and take a heart what do you do after?

Thanks! Glad you like it!

you gotta walk all the way back out of the dungeon. Transporting you back outside automatically like in a zelda game wasn’t doable since that would take up too much space in the data to implement.


Any tips for defeating the slime boss? Its really hard to try to hit him with bombs.

I edited your last post to mark your hint with spoiler tags. This blurs the text unless you click on it. It’s a good idea to do this when posting anything that some people may not want to see.

To add spoiler tags:

  • Highlight the text you want tagged and then click on the “gear” icon at the top right of the editing window. Select Blur Spoiler to add spoiler tags to the highlighted text.


  • Manually add [spoiler] at the start of the text and [/spoiler] at the end of the text.

Ah thanks. I know about the spoiler tag but I didn’t really think that was a spoiler. I wish you could get auto transported outside the dungeon after beating a boss, but alas it wouldn’t fit. Maybe I’ll try and squeeze it in now that I’m thinking about it, I think I know of a place to get some space.

1 Like