Battery failure on Arduboy

I faced off some problems with my Arduboy. And I need help.
This thread was created in the hope that the process will be helpful, if someone ran into this problem ever again.

I have my Arduboy off (power switch off) for a week or so half a day. And then something decided to creep on:
Disconnected to power, it will not start. When I turn on the power button nothing happened. After pressing a certain button (usually A_BUTTON or UP_BUTTON) it MAY finally begin and so on and so forth. Battery voltage reading was a 4.11V, so it is unlikely that it is battery issue. Didn’t check with my multimeter, though.

When connected to power, the red light (charge light) will not light(when power switch is off). The laptop cannot detect it at this time (“USB support” was offline now.) When I turn on the power switch, the red light will finally light up, but the arduboy won’t begin. I also had to press a certain button (UP_BUTTON or A_BUTTON) for it to begin, and after that my laptop can detect it. (“USB support” was online now.)

The current software on there (my ASTEROIDS, which worked yesterday) can run at this stage, but it happened to me that my Arduboy can crash unexpectedly, usually during changes(of program state) in the game or a certain button press. The rawADC included in source code also upset the MEGA32U4 from time to time.

Then I immediately decided to flash another thing onto there (assuming it was bad “code” in PROGMEM.) The problem still occurs. I then decided to clear the EEPROM (with the simplest code I came up with). Didn’t solve the problem. Then it won’t begin after being flashed (which is quite odd), and I now had to HOLD (UP_BUTTON) for the chip to be powered. Releasing the button will immediately shut the processor.
Then I flashed Hello World onto the chip (holding UP_BUTTON all the time.)
The “USB support”, however, was constant all the time. The COM port didn’t jump around, and nor is it COM 1.

Oh, and the reset button won’t do the trick.

Need help identify the problem.

Just spitballing but I wonder if it is something physical like a cold solder joint somewhere and pressing buttons slightly flexes the board allowing it to work (would explain why you have to hold the button for it to work). A way to test this is to put it in the fridge for a little bit, test it and warm it up a bit with a hairdryer and retest to see if there is a consistent working and not working condition. Or just carefully visually inspect all joints.

I think Xavier has had this unit for a while so a cold solder joint is unlikely.

@CDR_Xavier you have been playing with battery readings and you obviously have had the unit apart to read those battery settings. Why not explain what you were doing recently - battery discharging, recharging and any test or software you might have loaded?

1 Like

:P Yeah I was playing around something like that.
But no, I didn’t take the Arduboy apart. (unlike what you liekd to do…well, sort of.) After I developed the function. (I might try, though. But I seem to be unable to locate my multi-meter.)

I integreted my battery-reading function into my Asteroid game, tested it, and replaced the old code with it. That happened … 2 weeks ago, and code is on Github. Code was the newest version.
I didn’t upload another thing since that.
It is unlikely to be either software issue or a cold solder joint, because it was literally working …20 hours ago. With the same game.(latest version Asteroids)
I didn’t put it into water, I didn’t put it on top of fire, didn’t step onto it, and I didn’t expose it to gamma radiation (strong enough to destroy the board). In fact, this thing didn’t even pass a single security X-ray scanner yet (was always in my pocket)
It smells to me that the code the board had was really, really bad.

I do remember it having fallen from a height of 1 meter / 40 inches. Twice.

This is very unlikely to be a software issue, this is almost certainly a hardware issue.
E.g. maybe it was left by a radiator or someone else dropped it onto a hard floor and didn’t tell you.

It could be the battery.

Dropping it would possibly be enough to rupture the battery, or leaving it on charge for long enough that it got particularly hot.
That’s what killed my 3DS battery - it still works but unless it’s plugged in, the battery charge goes within a minute or two, hence I have to have it plugged in to use it.

Or it could be the computer that controls the battery broke somehow.
Or it could be age. How old is your Arduboy?
Li-ion batteries aparently only last 2-3 years from the date of manufacture, even if you don’t use them.

Your best bet is probably to try to replace the battery if at all possible or to fill in the contact form and see if they can find out what’s wrong with it, and if it is the battery, if they’ll replace it for a small fee.

I don’t think it was the battery issue, though…
The battery LOOK healthy. No swelling at any degree. (beside the two strips of … electrode making a slight bump on there)
digging out my multimeter…
The battery used to measure a healthy 4.0V, but why am I getting zeros now…
I DESTROYED THE CATHODE!!! :coffin:
OOF.
:anguished: :anguished: :anguished: :anguished: :anguished:
The “cool drawing” on the back wasn’t helping.

What is it? A lithium-ion battery or a Lithium polymer battery? (need to determine the best way to dispose the battery)
Can I get a replacement part?


Next time for me to receive anything was … 3 month later? :anguished:
Adding an item to my ever-growing list of stuff…




BUT, I do have this…


and I just bought a fresh roll of double-sided tape…

:open_mouth:
But hmm it is not working…
So the Arduboy have to detect something that is NOT 0.0V to run…
Does adding a capacitor will work?

Nope. tried. But at least that shows that the solder pad was more resiliant than I’d thought.
:anguished:
But I HAD a piece of lithium-ion battery. It just won’t fit.
That’s fine. I broke it out using wires.


But does it work?
:yum: :

Don’t even question my soldering skills.
New battery voltage at 4.022V with 140MAH, made 3 years ago. (which is OK, consider the battery’s optimum storage was 3.8V, a 4.0 V aren’t too bad.
Need to grab the slim battery to fit it inside, still.
Thanks @Pharap.

1 Like

So … are we saying the original battery was no good? Or had you broken a connection to it?

1 Like

I broke the battery’s cathode (+ tab).
The battery tabs are actually surprisingly durable. So I have no idea why the cathode broke. Took me 20 flips to break the anode(- tab).
But now I can enjoy the “Beautiful drawing” unobstructed by the slab of battery…
I still need help finding a replacement…

With the battery outside (and a bunch of cable with it too), I have decided to make a case for this thing holding onto the case…


Well, ignore the strap, because I cannot find another way to tie this down yet. (you can see the screw holes I made, but there are no long screws in my inventory that fits…)
But I think it was pretty cool. With a hint of Frankenstein with it. (especially like the bar over the battery)
Making my battery feel at home…

BY THE WAY, no one had told me what battery the “original” Arduboy had, and I have no idea still, on how to render it safe.