Black screen on boot with Arduboy2 games?

Here is the problem: whenever I upload an Arduboy2 game to my Arduboy, the left LED flickers rainbow and I get a black screen. I have uploaded games using the original Arduboy library and they work. I tested this using the example projects for Arduboy and Arduboy2. I have the libraries ATMlib, ARDBitmap, ARDVoice, Arduboy, Arduboy-TinyFont, Arduboy2, ArduboyPlaytune, ArduboyTones, FixedPoints installed on a fresh Arduino 1.8.5 installation. I am running Lubuntu 18.04. Does anyone else have this problem? Thanks in advance!

UPDATE: When I upload Arduboy2 games while the system is on, they work until I turn the Arduboy off. Then, the black screen error persists when I turn the system back on.

UPDATE: The rest of the system works but there is a black screen.

Even HelloWorld?

#include <Arduboy2.h>

Arduboy2 arduboy;

void setup(void)
{
	arduboy.begin(void);
}

void update(void)
{
	if(!arduboy.nextFrame())
		return;
		
	arduboy.clear();
	arduboy.println(F("Hello World"));
	arduboy.display();
}

You mention Arduboy2 in the subject, have you attempted to load a HEX file that uses the new library and determined whether that works? (The assumptino here is th compilation and / or uploading process from the IDE is the issue).

UPDATE: When I upload Arduboy2 games while the system is on, they work until I turn the Arduboy off. Then, the black screen error persists.

You need to have the Arduboy on, otherwise the screen will be black (off) :slight_smile:

When you refer to the system, do you mean the ‘Arduboy’ ? When you turn the unit back on, are you connected to the USB power or are you disconnected from the computer and on battery? Could this be a dead battery issue?

1 Like

I think that he know how to turn things on and off and stuff…
I assume it is the bootloader thing.
He mentioned the rainbow LED, so I think it is also not dead battery.
@TechieGaming
If you turn on your arduboy (without charging it) will the LED light up?
Does the computer recognize the arduboy when you plug it into your computer?
Does the Arduino IDE report a successful upload when you upload a sketch for arduino?
for that, remember to choose board (Arduino Leonardo), the COM where the arduboy appears.
Have you tried flashing the arduboy in flashlight mode (hold UP_BUTTON), then turn on power?

so the error is only with library Arduboy2? That means a Arduboy (classic/old/one) file will be flashed. If that’s the case, check the board and…maybe, reinstall the library.

Yes, that was a joke.

1 Like

If the game work initially, I would doubt the library is at fault. It could never hurt to refresh it though.

Could an EEPROM fault cause this? You know, since the Arduboy2 library reads a few locations in EEPROM.

To rule out a corrupt Arduboy2 library. Try to reinstall it.

Have you tried installing a game that uses Arduboy2 via the Arduboy Manager?