Blob Attack - First native TEAM a.r.g. game


#1

Our very second game for Arduboy, but our first native game.

Here you have a video:

Manual, media, download and technical are all on our website:

http://www.team-arg.org/blba-manual.html


What is your favorite game?
"Semi-Official" Game List for the Arduboy
"Semi-Official" Game List for the Arduboy
#2

Awesome, but all your games are :wink:


#3

This is cool! It’s awesome to have a puzzle game for the Arduboy. Great work!


(Luke) #4

Thanks TEAMarg, got my arduboy yesterday. Is there a way to save the game and continue later? I racked up a good score but as soon as I turned it off and back on again, it was gone…


#5

Thanks for playing our games.

The idea for the game was to NOT have a save option, just like the old days.
The other thing is, their isn’t much room left … We used almost every byte for getting the graphics in …
We even had to write a compression method for the graphics, because it wouldn’t even fit with the normal libraries.

BUT we have like 852 bytes left, so I’ll look into it :slight_smile:

I would make an autosave function, that saves the game after every drop and when you start the game, you get the option to play a new game or a saved game.


(Luke) #6

Thanks, it’s good fun. It was just a shame to turn it off and lose the score but I understand the limitations.


(Ross) #7

Feel free to take a picture and tweet it too https://twitter.com/ArduboyScores :smiley: @JO3RI and I started that account to try and allow people to post scores for the Arduboy and “save” them. It would be nice to have a bot on that channel, so we can catalog everything, but haven’t quite got there yet ; )


#8

Thanks for an exciting game. I and my wife are really enjoying this game.
I found a bug, I think. Blobs in the leftmost column would not vanish when linked in T or L pattern.
I think if condition in “leftIsSameBlob” function should be changed as follows.

boolean leftIsSameBlob(int array_x, int array_y)
{
//if ((array_x - 1 > 0 ) && (field [array_x][array_y] == field [array_x - 1][array_y])) return true;
  if ((array_x     > 0 ) && (field [array_x][array_y] == field [array_x - 1][array_y])) return true;
  else return false;
}

#9

Hi @itoda3,

Thanks for your post. Did you try this? I’ll try it too, but I’m not that good a gamer … :smiley:


#10

Hi @JO3RI,
I tried this and went well!. Thank you.


#11

@itoda3 I think you’re right :smiley: I have looked some more in my code and this part:

boolean leftIsSameBlob(int array_x, int array_y)
{
  if ((array_x - 1 > 0 ) && (field [array_x][array_y] == field [array_x - 1][array_y])) return true;
  else return false;
}

indeed the array_x -1 > 0 is meant to make sure we stay within the play field boundaries, but now we actually only start checking at the second column and not the first column). SO … it should be array_x > 0 like you said.

I will be reorganizing the code, while removing this bug, so it might take a little bit longer before I upload the new version to our website.

Thanks again for finding and solving this bug @itoda3


#12

And … ‘trumpets playing’ we fixed the bug and uploaded v1.6 of Blob Attack.


(Jordi Bayó) #13

I just received my Arduboy this morning…

Only unpacked, charged, and played Blob Attack (preinstalled).

A fast question… Have sound the version preinstalled? I no hear none… :frowning:

AND… Congrats for your spectacular games, team!!!


#14

Hi @Hark0,

The pre-installed game has sound, but you can toggle it on/off in the menu (conf). The sound is not more than some blibs and blobs and isn’t very loud (you will not hear it on a bus).

You can always upload this demo: demoScene - The first demo WITH 4 channel tracker music

It should play music, even if you have muted the sound in a previous loaded game.

If you still don’t hear a thing, you might have a loose wire …


(Jordi Bayó) #15

Hi!

Thanks for your reply… I tried again… and YES!!! I HAVE SOUND!!! (very low volume :confused: )

I try your other games… I think are a very good combination of look/gameplay.

:wink:

Cheers from Barcelona, Spain.


#16

Ok … I have to say this … I can’t resist :smile:

I know nothing, I’m from Barcelona


(Jordi Bayó) #17

:open_mouth:

Cullons!!!
:laughing:


(Sebastian Perez Galarza) #19

3 msg same problem… DUDE!:smiling_imp:


#20

@RamonML the problem is not even the games, but your device not being recognized. Use this forum to find the proper solution for you problem :slight_smile: (hard reset or wrong port selected)

how do I know:

Caused by: processing.app.SerialException: Error usando el puerto “/dev/ttyACM0”

I’m going to remove this and your other posts


#21

I don’t know what must I do.