Blob Attack - First native TEAM a.r.g. game

Thanks for playing our games.

The idea for the game was to NOT have a save option, just like the old days.
The other thing is, their isn’t much room left … We used almost every byte for getting the graphics in …
We even had to write a compression method for the graphics, because it wouldn’t even fit with the normal libraries.

BUT we have like 852 bytes left, so I’ll look into it :slight_smile:

I would make an autosave function, that saves the game after every drop and when you start the game, you get the option to play a new game or a saved game.

Thanks, it’s good fun. It was just a shame to turn it off and lose the score but I understand the limitations.

1 Like

Feel free to take a picture and tweet it too https://twitter.com/ArduboyScores :smiley: @JO3RI and I started that account to try and allow people to post scores for the Arduboy and “save” them. It would be nice to have a bot on that channel, so we can catalog everything, but haven’t quite got there yet ; )

1 Like

Thanks for an exciting game. I and my wife are really enjoying this game.
I found a bug, I think. Blobs in the leftmost column would not vanish when linked in T or L pattern.
I think if condition in “leftIsSameBlob” function should be changed as follows.

boolean leftIsSameBlob(int array_x, int array_y)
{
//if ((array_x - 1 > 0 ) && (field [array_x][array_y] == field [array_x - 1][array_y])) return true;
  if ((array_x     > 0 ) && (field [array_x][array_y] == field [array_x - 1][array_y])) return true;
  else return false;
}
1 Like

Hi @itoda3,

Thanks for your post. Did you try this? I’ll try it too, but I’m not that good a gamer … :smiley:

Hi @JO3RI,
I tried this and went well!. Thank you.

1 Like

@itoda3 I think you’re right :smiley: I have looked some more in my code and this part:

boolean leftIsSameBlob(int array_x, int array_y)
{
  if ((array_x - 1 > 0 ) && (field [array_x][array_y] == field [array_x - 1][array_y])) return true;
  else return false;
}

indeed the array_x -1 > 0 is meant to make sure we stay within the play field boundaries, but now we actually only start checking at the second column and not the first column). SO … it should be array_x > 0 like you said.

I will be reorganizing the code, while removing this bug, so it might take a little bit longer before I upload the new version to our website.

Thanks again for finding and solving this bug @itoda3

1 Like

And … ‘trumpets playing’ we fixed the bug and uploaded v1.6 of Blob Attack.

1 Like

I just received my Arduboy this morning…

Only unpacked, charged, and played Blob Attack (preinstalled).

A fast question… Have sound the version preinstalled? I no hear none… :frowning:

AND… Congrats for your spectacular games, team!!!

Hi @Hark0,

The pre-installed game has sound, but you can toggle it on/off in the menu (conf). The sound is not more than some blibs and blobs and isn’t very loud (you will not hear it on a bus).

You can always upload this demo: demoScene - The first demo WITH 4 channel tracker music

It should play music, even if you have muted the sound in a previous loaded game.

If you still don’t hear a thing, you might have a loose wire …

Hi!

Thanks for your reply… I tried again… and YES!!! I HAVE SOUND!!! (very low volume :confused: )

I try your other games… I think are a very good combination of look/gameplay.

:wink:

Cheers from Barcelona, Spain.

1 Like

Ok … I have to say this … I can’t resist :smile:

I know nothing, I’m from Barcelona

:open_mouth:

Cullons!!!
:laughing:

3 msg same problem… DUDE!:smiling_imp:

@RamonML the problem is not even the games, but your device not being recognized. Use this forum to find the proper solution for you problem :slight_smile: (hard reset or wrong port selected)

how do I know:

Caused by: processing.app.SerialException: Error usando el puerto “/dev/ttyACM0”

I’m going to remove this and your other posts

I don’t know what must I do.

Sorry man … :innocent:

Post about your problem in the correct section :slight_smile:
but I guess you did: (SOLVED) Can't load any sketch which after can load

Thanks. :slight_smile:

1 Like

We released V1.8.1:

  • added animations
  • speed increases at certain amount of points
  • blobs POP when cleared
  • fixed infoScreen

As always, if you compile yourself make sure you update your libraries (Arduboy2, ATMlib) and use the latest Arduino IDE. Or use the GameLoader to upload the compiled .arduboy file.

2 Likes