Brand new arduboy - charges & yellow light flashes when plugged in, doesnt show up anywhere on windows


#1

Just got my arduboy in the mail about 20 minutes ago, and I’m having a pretty big issue. Windows does not recognize it… at all. I’ve tried 3 cables, all of them charge it, and when the arduboy is on and plugged in, a yellow light will flash. When I go into the arduino ide, there are no ports, and when I check device manager it is not there. Windows also does not make any sound when it is plugged in. I’ve tried all the USB ports on my computer, all of them work with other things, but none will work with the arduboy.
edit: tested on my gpd win, and it is recognized fine, but thats not my main computer. Any idea why my pc doesnt even make a sound when its plugged in?
edit #2: dont think this makes a difference, but my main pc only has USB 2.0 ports, while the one on gpd win is a USB 3 port (i believe).


(Stephane C) #2

USB 2.0 or 3.0 should not matter… I tried both and works the same.

The yellow led flashing usually means that it is connecting properly. The red led means it’s charging…


#3

Not sure why it wasn’t working, however I got it to work. I noticed my drawing tablet was also not working for some reason, so I decided to restart my pc and now it is working fine. Seems like it was just windows being windows…


#4

Yeah, I’ve had instances where on my desktop if I haven’t rebooted it in quite awhile it will randomly stop recognizing any usb device (or sometimes the second internal sata hdd)! A simple reboot fixes it though so no biggie.