Bricked, strange loop, too dumb to reset

Well i’m really special talented.
I uploaded a too big app to the boy and since then it does this.


I needed to take my arduboy apart because while i tried to reset it, the black plastic and the metal cage broke away so i couldn’t press it anymore. Now i have to press the small metal plate down to reset it. - yeah i know, talented…

I’ve noticed following behaviors:
When i plug the cable it sometimes stops the loop and sometimes it continues it infinitely.
When i press reset it stops immediately and the red flash it lightning up.
When i press it again nothing happens. (no yellow data light)

Any help with this? :frowning: i want to continue my game >_<

Yes i have tried this one.

Try pressing and holding the UP button while powering up the Arduboy. This will put you into flashlight mode, but because your unit is one of those with the RGB LED installed incorrectly, the RGB LED will remain off and the display will be blank.

See if you can now upload a new sketch while in flashlight mode.


When i do that, the arduino ide recognizes the boy and it shows up at the ports.
But when i press upload all leds at the bottom flash up and nothing happens. a few secs later the arduino ide says that no devices has been found at the selected port.


When repeat it and press the reset button in the flashlight mode the red led flashes up but the ide doesn’t find a device and i can’t upload neither.