Bring your Arduboy back from the dead (burn bootloader)


(Fernando Jerez) #41

No fancy clamps, using my hands to hold the pins and clicked the mouse with the elbow. I think ‘Jugglering’ it’s the correct word.:smile:

A bit of double sided tape to keep the Arduboy in place and after two tries it work!


(Scott R) #42

Got my programmer and killed it trying to lock it :cry:
is it safe to power it from usb or the battery to flash it? as it doesn’t seem to power from the test pads.


(Erwin) #43

Why do you think you killed it?


(Scott R) #44

I connected the programmer with the arduboy off and something light up, I hit burn bootloader and It got as far as Reading########################### and the light went out now all I can get is a red LED when plugging in USB reflashing fails:

avrdude: auto set sck period (because given equals null)
avrdude: warning: cannot set sck period. please check for usbasp firmware update.
avrdude: error: program enable: target doesn't answer. 1 
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.


avrdude done.  Thank you.

Error while burning bootloader.

I’ve double checked cables continuity with a multimeter and all are fine from the solder pads on the programmer through to the pins I used.


Connections are:
VCC=Red
GND=Black
Reset=Green

CLK/SCK=Green
MOSI=Yellow
MISO=Blue


A Dead Arduboy + Raspberry Pi + AVRdude + Noob
(Erwin) #45

Hard to tell. At first glance it might be that you are not connecting all pins at the same time. You need pogo pins or something more flexible in my opinion.

Are you sure that you did not reversed VCC and GND while trying to program your Arduboy? (that is the only thing it might be dangerous in my opinion)


(Scott R) #46

It’s virtually impossible to reverse them GND is fixed in the centre by the header pins with each cable facing the same direction so I know top and bottom orientation and I specifically used red and black on those pins for that purpose.


(Holmes) #47

Thanks for this thread! Love it! Glad to see a conversation about this in English. :stuck_out_tongue:


(Scott) #48

Setting the USBasp programmer’s jumper to 3.3V could actually be more dangerous than using the 5V setting.

With it set at 3.3V, and with the Arduboy’s power switch off, the Arduboy’s processor and display will be powered at 3.3V by the programmer. However, the signals output from the programmer will still swing up to 5V. Therefore, you risk damaging both the processor’s inputs (specified as maximum Vcc + 0.5V = 3.8V) and the display’s inputs (specified as maximum Vdd, which will be Vcc = 3.3V in this case).

With the programmer set at 5V, both power and signal swing will be 5V, so you won’t be exceeding the maximum voltage for an input. And, since the processor is specified as maximum 6V for power, there’s no risk damaging the processor. So, only the display is at risk, since it’s specified as maximum 4V.


(Scott) #49

Yes, powering from the USB or the battery is just as safe (whatever you feel that is) as powering from the programmer.

If you’re going to do it this way, DO NOT connect to the VCC pad on the Arduboy from the programmer. Only connect GND and the other signals. If you connect a voltage higher than the battery voltage to VCC, the battery could get hot and/or be damaged and/or explode.

You should power up the Arduboy and the programmer separately, then only connect the two after both are powered up. You should also try to connect GND first, before connecting the other signals.


(Scott R) #50

It seems I’ve successfully gone from a slighty flawed Arduboy to a completely dead not so great paper weight.


(Pharap) #51

Demo, nihongo ga totemo sugoi da!
Nihongo ga ichiban gengo da!


(Erwin) #52

I would try again making sure that all the pins are making contact. If you killed the uC, then it is over. But as I say in the instructions, one of the steps is powering off the Arduboy (step 1). I am guessing that having the battery engaged + VCC connected might damage the microprocessor.


(Scott R) #53

I’ve not tried using the battery or USB for power yet but have had no success either with the jumper set at 5v. I followed your steps pretty much to the letter apart from having the jumper set to 3.3v (what I thought was safer from reading MLXXXp’s post that I now know I’ve misinterpreted) and using the cables I had to hand and it almost completed the flashing process. I’ll try soldering some cables directly between the programmer to the pads ensure a proper connection over the weekend as a last ditch effort if that doesn’t work then I doubt an alternative power source will make any difference.


(Erwin) #54

OK, I suggest using pogo pins or another method. Maybe those fancy pcb clamps. Soldering something on the pads might damage them. I am not sure how strong they are but the repair would become real hard if you have to start scratching the soldermask after losing a pad.


(Scott) #55

They’re just regular etched pads. As long as your iron isn’t set too hot (only a bit hotter than what’s required to melt the solder), and you leave it in contact only long enough to create a proper joint, then the likelihood of damage is quite low.

Of course, you should be careful not to pull hard on the wires that you’ve soldered to the pads.


(Kevin) #56

Just as a point of reference, if someone has an Arduboy that failed during normal use and doesn’t feel comfortable doing these steps, you’re welcome to use the contact form to let us know about what happened and we may be able to help.

This is a great reference for developers who want to modify (correct) the boot loader or dive deeper into the development of the system, but you shouldn’t feel like this is necessary if you’re having problems with your Arduboy.


(Scott R) #57

I had no luck soldering directly to the pads so it seems its toasted.
The soldering no doubt will make most of you cringe but I’m out of flux and only own a cheap 40w iron. All connections have been checked for continuity from the edges of the pads to the corresponding pads on the programmer so at this stage I’m 99.9% certain I am Arduboy’s Kryptonite.

For reference I have included an Image

Edit:
Found some old solder grease (dates back to Woolworths) and re did the joints and still no joy.
@eried Here’s the result after one ugly solder attempt plus one using grease and a desolder using a 40w iron. The pads are pretty resilient.

@bateske MISO and MOSI are difficult to read due to the line running through the text is this something that can be remedied easily in the future?


(Erwin) #58

So, no response at all? I guess the uC was burn for some reason. Good to know that the pads are not that weak :slight_smile: thanks for sharing.

PS: Also CLK should say SCK


(Scott R) #59

I’ll order another programmer or look into using a Pi “just in case” the issue lies there

Although I have checked the output voltages with the jumper and got 3.28V & 5.19V so precaution should be taken as stated by @MLXXXp further damage could be possible to your hardware, especially in the wrong hands like mine :joy:

I’ll create another topic for my issues as I don’t want to hijack your thread any further but will post back here if I get a success.


(Fernando Jerez) #60

Posting here is ok. We can see your progress and learn something.
I have no idea what happens with your Arduboy. I have the same USB programmer and all the wiring seems to be ok. Worked for me
A question: This little device between the USB and the programmer looks useful for arduino projects. How can i found it?? USB-multimeter/polymeter??

Good luck!!