Bring your Arduboy back from the dead (burn bootloader)


(Scott R) #61

The USB voltage/ current meters can be found on eBay and similar sites for between £2-£4 I originally bought this one for finding the best positions with my solar panel on camping trips. This one looks interesting as it covers a large range of voltages

Managed to get a Pi setup and hooked up to the Aduboy I suck at Linux and have never used avdude before would this be correct to flash it?

pi@raspberrypi:~ $ sudo avrdude -p m32u4 -C ~/avrdude_gpio.conf -c pi_0 -v -U flash:w:/home/pi/Bootflash_program_game.hex:i -U efuse:w:0xcb:m -U hfuse:w:0xd8:m -U lfuse:w:0xff:m


(Fernando Jerez) #62

I never used Avrdude from command line. but the Arduino IDE is available for linux.


(Erwin) #63

Tried with solder. Works great too. For my last Arduboy I am thinking on making a “test bed” with pogo pins.

Just an extra tip. If you want to add parameters to the AvrDude.exe call that the Arduino IDE executes, you can add new entries to that menu with your custom params:


(Erwin) #64

What are you trying to achieve calling avrdude directly? as I added in my last post, you can modify the parameters that Arduino IDE use


(Scott R) #65

I’m using an RPI over ssh I’m going to take a look at using the IDE on it but not sure if GPIO is accessible from there as a programmer.
Currently using pins

GPIO–|—ARDUBOY
15----------Reset
17----------VCC
19----------MOSI
21----------MISO
23----------SCLK
25----------GND


(Scott R) #66

I was thinking of making a Programmer/unbricker but using a RPi so I can do it at the touch of a button or two.
Annoyingly the two rows of pads are off set I hope I can get round this with lego :joy:


(Erwin) #67

Hahahah! unbricker device. Sounds so overkill. You can also drill holes in the aluminium case to get easier access to the programming pads.

After the first reflash, I have not experienced any more issues (after the first flash the get the right fuse configuration). Also my uploader protects the Arduboy futhermore :sunny: so I am pretty confident now.


(Kevin) #68

I couldn’t come up with a real clean design, but if someone has an idea for doing a pogo pin backpack then I could make a bunch and put them on the site for cheap.

The problem is how do you hold it down? We use a jig in the factory, these clip ideas are good…


(Scott) #69

You provide pins with shoulders that the circuit board’s 2 bottom corner holes go to into, to align the pads over the pogo pins.

Hand pressure would probably suffice for holding the board down but you could also use some kind of a clip or make the alignment pins thumbscrews.


(Kevin) #70

This could work but you would still need to hold it down or clip it somehow. I like your idea using the screw bosses for alignment, I hadn’t actually thought about that. Maybe with that being able to align the X/Y axis the Z wouldn’t be so difficult to manage with one hand.

I don’t know how many people would buy this, it’s probably better for me to make a handful of these myself first. I’ve got quite a few bags of pogo pins so maybe I could sell them both assembled or as a kit for people who don’t mind to solder and save 5 dollars.


(Erwin) #71

I am waiting for 2 events, first I need to receive my aliexpress pogo pins (already ordered a bag but forget where I put them) and an evil hex file needs to kill my last untouched Arduboy.

Then I want to make a simple 3d-printable adaptor for flashing it. I do not want to use the screw holes, but the outer shape of the Arduboy bottom part (to avoid having to lift the pcb and make the flashing process as fast possible)… and get that in thingiverse of course


(Scott R) #72

The two alignment pins could use longer screws to fix to the existing screw holes on the face to secure it.


(Kevin) #73

Like a cartridge slot?

Actually this was originally the plan for the Arduboy. It would have been a 328p with the FTDI on some kind of dongle. But the need to charge it on the go and all of the other features of having usb is too convenient… but it was something I was working on to try and keep it as thin as possible.

I’m realizing that if I just included standoffs and screws with the PCB you could just bolt the second board onto the back.

The 3d printed case could be an “upgrade” from the bolt together kit that users could download.

@eried is always coming up with stuff faster than I can put it together lol. What do you think? Could we make the PCB so that it could serve dual purpose bolt on and be loaded into a 3d printed cart holder? I think so!


#74

Hello,

my Arduboy (pre-order version) seems also bricked, after I uploaded a new sketch, the IDE could not find arduboy anymore.

I tried the reset button, flashlight mode and also new micro usb cable. So I had to try this, I got my isp programmer and some wires and set all up, started the process andavrdude told me, he had problems with writing.

here is the avrdude log

I also double checked the pins, not that I got maybe the wrong ones, I am still unsure, but I hope someone can help me out

my setup:
arduino: 1.8.1
isp-programmer: usbasp (MTS1EU USBASP AVR Arduino compatible)
pc: macbook pro retina 2012


(Pharap) #75

Which sketch did you upload?

(InB4 Arduventure.)


I’m not completely certain, but I think the lock fuses on some of the kickstarter Arduboys weren’t set properly, so it could be that the bootloader had been corrupted since the avrdude output states Error while burning bootloader..


In case anyone with more insight than me read this, other suspect lines are here:
avrdude: reading input file "0xcb"
avrdude: writing efuse (1 bytes):

Writing |  ***failed;  
################################################## | 100% 0.06s
 
avrdude: 1 bytes of efuse written

And here:
avrdude: verification error, first mismatch at byte 0x0000
0xff != 0xcb
avrdude: verification error; content mismatch


#76

thanks for the fast respond, my own sketch, I went bit over the line, I think with the flash memory.

I’m not sure, but I thought my bootloader got corrupted. I have guessed it’s maybe not protected from too big sketches

as you suggested, I also think that he had problem with writing the efuse byte, but I have no idea, if its because of wrong pins or something else.


(Erwin) #77

Are you using the arduino ide burn bootloader option?

I do not exactly remember if the lock bits were set at the beginning or at the end, but it seems weird that the log does not contain any reference to the bootloader file itself


#78

yes (1.8.1), like the guide. (although I could not find the verbose option)


(Erwin) #79

Is in file/preferences, two checkboxes, one for the compile process and the other for upload


#80

sorry, my fault they are checked! Does there any other log exists with more output than the console?