Buttons not responsive, with weak battery life


(Charleen) #1

Hi all,

I just bought my Arduboy two weeks ago and i was so excited to play my arduventure and realized my buttons are not responsive. At times i had to click multiple times on the same button before it responses. I barely started playing and was at that part of the game where i get to “choosing my name” before i switch it off because it is such a bummer to play it when my buttons were giving me problems.

On top of that, i realize my battery doesn’t last? I gave it a full charge, and two days later i tried switch on and the battery was dead. it Do any other players face the same issue? I tried to email to customer support more than a week ago and is no response. Would appreciate any suggestions or feedback, thanks!


(Scott R) #2

I hardly ever charge my arduboys and I’ve never had a noticeable issue with battery drainage with the unit switched off for weeks.

Maybe @bateske can chime in?


(Charleen) #3

hey, thanks for your response. it would likely mean there is some issue with my arduboy. I am still waiting for the service team to response, still hoping they would help me on this.


(Kevin) #4

@xueli_charleen please write in to arduboy.com/contact and let us know if you haven’t already and we can try to help you from there.