Can not power the board anymore from usb port

hello

i think i did something wrong
yesterday i received my dev kit and when i putted it on the usb i had the possibility to play the game on the the board
without the battery

now after i went back from the shop for the battery i wanted to play with the board but the board wil not go on when i plug in the usb i can only with the battery

for wright a code to the board it was also not possible anymore

but with the reset trick on the pins on right moment it was possible
but with a fresh code of ardubreakout was this problem not solved

just always need the battery to power the board and not everytime wil the my comp (win7) recognize the board when i do the reset trick

can someone help me?

Hello! Thanks for trying out the dev kit, and sorry to here you are having some problems. I guess we will try some basic troubleshooting steps and see how it goes. I imagine we can get this unit going again.

Troubleshooting steps:

  • How does the device show up in the device manager for Windows? Can you screen cap the device manager for us?
  • Have you tried other usb ports on your machine?
  • Have you tried other cables (microusb cables are pretty delicate and can have wires crease/crack)?
  • What happens if you plug it into another machine, if that’s possible.
  • I know in the last issue post there was a user who had luck reinstalling the driver, have you tried this yet?

Let us know what happens when you try these things and we can go from there.

Also have you tried reloading the sample game, or are you trying to load custom code?

hello

thanks for helping me

i know it’s sad but i thing there is something wrong with 5v powering of the board

when i power the board on from the battery the arduboy works fine. just for playing the game on it

OK thanks for doing some of the ground work. It may be that unit is defective, or was damaged. Perhaps @bateske would have a method for checking voltage on the traces coming off the usb port, but perhaps not. Either way @bateske will follow up shortly with a resolution.

What sketch is it running? Are you still running the default sketch?

You tried doing the reset procedure? The reset only lasts for 5 seconds so you have to time the upload of a new program exactly at the right time.

If you are still having problems you can send it back we will get you taken care of.

thanks @bateske and @ekem for the reply

@bateske first i had the default one and there was the problem suddenly
did a successful new one with the reset procedure from the online sketch of the same game on Github library

but still have the same issue

notting works. can just play the game from powering with the batt. no flashing new program not possible. i don’t know what i did wrong. if i want to send it back. what is the address to send it @bateske

Has he gotten back to you? Otherwise I will have you ship it to myself.

This same thing has happened to me as well. Was working fine for a while but at one point it stopped being able to upload via USB, and seemed to be because the board was stuck and not accepting an upload. Tried to reset by the method described shorting the pins, yet now I can’t seem to get it to show up on a computer.

Battery still works fine, but currently there is a sketch on the board that does nothing so it’s pretty useless.

Ok thanks albert. I’ll actually make sure bateske gets these and not myself, as it would be more useful for him to diagnose the cause here.

Please email me and we will get in touch ill let you know my shipping address, then I can take a look and see what happened. Sorry for the trouble!

Go ahead and me an email I can give you an address to send it and we can figure out what happened.