Can’t upload new game

I’ve tried downloaded “arduboy uploaded” “arduboy manager” I already have arduino ide downloaded… everytime I click transfer, my arduboy just restarts that game it has downloaded and that’s it.

check this

1 Like

Sweet … I can use that at work (about once every hour).

  • Which game do you already have loaded on your Arduboy?
  • Have you tried holding the up button when you turn your Arduboy (to go into ‘flashlight’ mode) on before beginning the transfer?
  • Have you tried using the reset button when uploading?

Same here. Though I’m affraid the OSX caption bar will be too confusing for Windows users here.

1 Like

My arduboy came with sirene downloaded on it, I was able to download another game called “space cab” after a lot of trial and error trying to download games, I’m still not sure how it even downloaded… I tried the flashlight method, didn’t work. The restart one I haven’t tried, I was trying to get games from “arduboy uploader” “arduboy manager” “project ABE” “arduino”

You’re best off using the ArduinoIDE for uploading,
it’s less error prone and easier to debug than the other systems.
(No offence to the people who wrote the alternatives.)

That means compiling the code from source, but it’s worth it.

Did the screen not go white?
Or did it go white but the upload failed?

The screen went white, but it just restarted the game. Also, on arduino I get the error message “library not found”

A very general solution Using Arduino IDE:

  • open blink example sketch from File > Examples > basics and go to the newly created window

  • Go to preferences (CTRL+Comma) and at the option Show verbose output during:
    put a checkmark at the options compiler and upload and click OK

  • Press reset button on Arduboy

  • quickly (within 8 seconds) go to tools > port and select com port (usually the highest number)

  • Ensure Leonardo board is selected from Tools > Board menu

  • click upload button (or press CTRL + U)

  • When you see the text PORTS {} appear in the black window press the reset button on Arduboy and wait

  • After the upload is complete you can upload an Arduboy sketch / game again normally

The reset button on Arduboy is left from the micro USB connector. Use a toothpick, a SIM eject tool or something similar to press it.


Now why can’t it detect your browser version and show appropriate images?

Nice! That solution worked, thanks for the help!


I did all of this but I’m still unable to upload. ArduboyUploader gives me a red exclamation point error screen, and Arduboy Manager hangs forever. tried arduboy game loader and it doesn’t get past this point. maybe it doesn’t have a bootloader?

I’ll have to edit this post to respond for the next 22 hours due to limitations on new users.

I had the same issue with the game “Space Cab” I am stuck with it and can’t change it.

What a great game :wink:

Anyhow, have you tried this … How To Use Flashlight Mode To Fix Bricked Arduboys

I finally manage to fix my issue. I press restart button and load new game within 8 second after.
I am so excited about my Arduboy that I record a play through few of my favorite games so far :slight_smile: