Cannot Compile or Upload an Example Game: cc1.exe: error [SOLVED]

Hi there,

i always get this Error Message:

cc1.exe: error: -fno-fat-lto-objects are supported only with linker plugin.

exit status 1
Fehler beim Kompilieren für das Board Arduboy.

I cannot upload or Compile any example like “Hello World”.

Has anyone the same issue

Thank You

1 Like

What verison of the Arduino IDE are you using?

Version is 1.6.10

I think it is the newest one, I downloaded it today.


1 Like

I’m getting the same error as well on a fresh install. I’m using version 1.6.10 too.h

1 Like

There is a solution to the problem. However, there is another problem with using the Arduboy library with Arduino 1.6.10 which results in the display being scrambled.

Until the Arduboy library is fixed, please use Arduino version 1.6.9.
Also, using IDE menu:
Tools > Board: > Boards Manager...
make sure that you are using “Arduino AVR Boards Built-in by Arduino” version 1.6.11

@MLXXXp Thank you! This Works fine for me :slight_smile: Good Job:relaxed:


Wow Arduino sure borked up this latest update! Stay tuned to more updates!

No they didn’t!! They went to a newer version of the compiler and made other changes that generates more efficient code, which is a good thing. A simple sketch consisting of just arduboy.begin() in setup() is now 1192 bytes shorter (9274 bytes instead of 10466 bytes)!

We borked the Arduino library by writing a function using open loop code that creates a timing delay by adding extra instructions that do nothing. The more efficient compiled code caused the overall delay to be too short, causing the function to write to the display too fast.

The blame for the display corruption problem that results from upgrading to Arduino IDE 1.6.10 is all on the Arduboy library!

My fix changes the function to a closed loop. Instead of a blind delay, it waits for the SPI controller to tell us that it’s ready to accept another character. With this change, the problem will never occur again in the future and is also fully backwards compatible with all older IDE versions.

Arduboy library V1.1.1 has now been released, with a fix for the display corruption problem when using Arduino IDE 1.6.10. You should be able to update to Arduboy V1.1.1 using the Arduino Library Manager.